sunxi: update image Makefile to reflect updated DTS structure in 6.6
authorZoltan HERPAI <wigyori@uid0.hu>
Fri, 8 Mar 2024 14:29:37 +0000 (15:29 +0100)
committerZoltan HERPAI <wigyori@uid0.hu>
Fri, 15 Mar 2024 17:30:12 +0000 (18:30 +0100)
For the ARM arch on 6.6, DTS files are moved into their vendor directories,
mimicking arm64. Reflect this in the image Makefile.

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
target/linux/sunxi/image/Makefile

index 738585accc86cc7983b9c0fd56f56989ec2780a8..1a12e6785d1d0148427b711f8137978a87111836 100644 (file)
@@ -35,7 +35,11 @@ define Device/Default
   KERNEL := kernel-bin | uImage none
   IMAGES := sdcard.img.gz
   IMAGE/sdcard.img.gz := sunxi-sdcard | append-metadata | gzip
+ifneq ($(LINUX_6_1),)
   SUNXI_DTS_DIR :=
+else
+  SUNXI_DTS_DIR :=allwinner/
+endif
   SUNXI_DTS = $$(SUNXI_DTS_DIR)$$(SOC)-$(lastword $(subst _, ,$(1)))
 endef