qt4: Fix non-GUI build
authorMichael Büsch <mb@bu3sch.de>
Fri, 27 Aug 2010 16:12:57 +0000 (16:12 +0000)
committerMichael Büsch <mb@bu3sch.de>
Fri, 27 Aug 2010 16:12:57 +0000 (16:12 +0000)
SVN-Revision: 22822

Xorg/lib/qt4/Config.in
Xorg/lib/qt4/Makefile

index 903850a9a431473f3aa4d1424c151b71359277f4..bf3fbbfce70e859d69f3b28caf5895892772772c 100644 (file)
@@ -1,6 +1,6 @@
 choice
        prompt "qt4 window system"
-       depends on PACKAGE_qt4
+       depends on PACKAGE_qt4 && PACKAGE_qt4-gui
        default QT4_WS_QWS
 
 config QT4_WS_QWS
index 160975f3b92c2e89d0eeb816af29b8cde677bd37..847034af130afe6e0301ee170cd35a9631e476c9 100644 (file)
@@ -258,6 +258,11 @@ endif
 ifeq ($(CONFIG_QT4_WS_X11),y)
   FILEPFX:=x11-
 endif
+ifeq ($(CONFIG_PACKAGE_qt4-gui),)
+  # If GUI is disabled, we use the X11 prefix. That's good enough, for now.
+  # The X11 files also work for non-GUI.
+  FILEPFX:=x11-
+endif
 
 define Build/Configure
        # NOTES:
@@ -300,8 +305,7 @@ define Build/Configure
                        -nomake translations \
                        -xplatform $(QMAKE_PLATFORM_PREFIX)linux-openwrt-g++ \
                        -platform linux-g++ \
-                       $(if $(CONFIG_QT4_WS_QWS),-embedded) \
-                       $(if $(CONFIG_QT4_WS_X11),-x11) \
+                       $(if $(CONFIG_QT4_WS_X11),-x11,-embedded) \
                        -release \
                        -confirm-license \
                        -opensource \