realtek: 6.6: refresh patch 310-add-i2c-rtl9300-support
authorMarkus Stockhausen <markus.stockhausen@gmx.de>
Sun, 8 Sep 2024 20:43:08 +0000 (16:43 -0400)
committerSander Vanheule <sander@svanheule.net>
Sat, 14 Sep 2024 17:58:55 +0000 (19:58 +0200)
No content changes. Due to kernel changes the patch hooks totally failed
and had to be fixed manually.

Signed-off-by: Markus Stockhausen <markus.stockhausen@gmx.de>
target/linux/realtek/patches-6.6/310-add-i2c-rtl9300-support.patch

index 2125aea77f0cf4af90984f4adb59e840fd686031..71df91bdacb7a76c0bfd5e729b0888e8026551cb 100644 (file)
@@ -17,7 +17,7 @@ Submitted-by: Birger Koblitz <git@birger-koblitz.de>
 
 --- a/drivers/i2c/busses/Kconfig
 +++ b/drivers/i2c/busses/Kconfig
-@@ -949,6 +949,16 @@ config I2C_RK3X
+@@ -1021,6 +1021,16 @@ config I2C_RK3X
          This driver can also be built as a module. If so, the module will
          be called i2c-rk3x.
  
@@ -31,16 +31,16 @@ Submitted-by: Birger Koblitz <git@birger-koblitz.de>
 +        This driver can also be built as a module. If so, the module will
 +        be called i2c-rtl9300.
 +
- config HAVE_S3C2410_I2C
-       bool
-       help
+ config I2C_RZV2M
+       tristate "Renesas RZ/V2M adapter"
+       depends on ARCH_RENESAS || COMPILE_TEST
 --- a/drivers/i2c/busses/Makefile
 +++ b/drivers/i2c/busses/Makefile
-@@ -94,6 +94,7 @@ obj-$(CONFIG_I2C_QCOM_GENI)  += i2c-qcom-
+@@ -101,6 +101,7 @@ obj-$(CONFIG_I2C_QCOM_GENI)        += i2c-qcom-
  obj-$(CONFIG_I2C_QUP)         += i2c-qup.o
  obj-$(CONFIG_I2C_RIIC)                += i2c-riic.o
  obj-$(CONFIG_I2C_RK3X)                += i2c-rk3x.o
 +obj-$(CONFIG_I2C_RTL9300)     += i2c-rtl9300.o
+ obj-$(CONFIG_I2C_RZV2M)               += i2c-rzv2m.o
  obj-$(CONFIG_I2C_S3C2410)     += i2c-s3c2410.o
  obj-$(CONFIG_I2C_SH7760)      += i2c-sh7760.o
- obj-$(CONFIG_I2C_SH_MOBILE)   += i2c-sh_mobile.o