projects
/
openwrt
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
40fd77f
)
build: remove @ as it's causing an error
author
Philip Prindeville
<philipp@redfish-solutions.com>
Tue, 19 Sep 2017 21:17:09 +0000
(15:17 -0600)
committer
John Crispin
<john@phrozen.org>
Wed, 20 Sep 2017 06:50:49 +0000
(08:50 +0200)
Since $(DownloadMethod/unknown) is being invoked in the expansion of
$(call locked ...) anyway, you can't have an @ because the shell
doesn't know what to do with it.
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
include/download.mk
patch
|
blob
|
history
diff --git
a/include/download.mk
b/include/download.mk
index 82a3dd2f988d28fc5ee6e74e0244ba315769c4af..0a25641738413379736c65b8e73938b2b51003d6 100644
(file)
--- a/
include/download.mk
+++ b/
include/download.mk
@@
-103,7
+103,7
@@
hash_var = $(if $(filter-out x,$(1)),MD5SUM,HASH)
endif
define DownloadMethod/unknown
-
@
echo "ERROR: No download method available"; false
+ echo "ERROR: No download method available"; false
endef
define DownloadMethod/default