samples: bpf: make the build less noisy
authorJakub Kicinski <jakub.kicinski@netronome.com>
Tue, 15 May 2018 05:35:06 +0000 (22:35 -0700)
committerAlexei Starovoitov <ast@kernel.org>
Tue, 15 May 2018 05:52:10 +0000 (22:52 -0700)
Building samples with clang ignores the $(Q) setting, always
printing full command to the output.  Make it less verbose.

Signed-off-by: Jakub Kicinski <jakub.kicinski@netronome.com>
Signed-off-by: Alexei Starovoitov <ast@kernel.org>
samples/bpf/Makefile

index 0036a77c2d97b1aa63529712303d0ccb85b7bdf8..62d1aa1a4cf3786da0d82a20e2937b96e22f2b49 100644 (file)
@@ -244,7 +244,8 @@ $(obj)/tracex5_kern.o: $(obj)/syscall_nrs.h
 # But, there is no easy way to fix it, so just exclude it since it is
 # useless for BPF samples.
 $(obj)/%.o: $(src)/%.c
-       $(CLANG) $(NOSTDINC_FLAGS) $(LINUXINCLUDE) $(EXTRA_CFLAGS) -I$(obj) \
+       @echo "  CLANG-bpf " $@
+       $(Q)$(CLANG) $(NOSTDINC_FLAGS) $(LINUXINCLUDE) $(EXTRA_CFLAGS) -I$(obj) \
                -I$(srctree)/tools/testing/selftests/bpf/ \
                -D__KERNEL__ -Wno-unused-value -Wno-pointer-sign \
                -D__TARGET_ARCH_$(ARCH) -Wno-compare-distinct-pointer-types \