projects
/
openwrt
/
staging
/
thess.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
bfeef9b
)
rkbin: add rk3588 support
author
Ben Whitten
<ben.whitten@gmail.com>
Thu, 13 Jul 2023 20:41:27 +0000
(21:41 +0100)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Sun, 11 Aug 2024 16:56:27 +0000
(18:56 +0200)
Adding support for the rk3588 platform
Signed-off-by: Ben Whitten <ben.whitten@gmail.com>
Link:
https://github.com/openwrt/openwrt/pull/15607
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/boot/rkbin/Makefile
patch
|
blob
|
history
diff --git
a/package/boot/rkbin/Makefile
b/package/boot/rkbin/Makefile
index 58098b8ea78b95c9c5444a62aea8672988005534..d895c06547b0b788efffa3badd280bc02695ccb3 100644
(file)
--- a/
package/boot/rkbin/Makefile
+++ b/
package/boot/rkbin/Makefile
@@
-57,12
+57,19
@@
define Trusted-Firmware-A/rk3568-e25
TPL:=rk35/rk3568_ddr_1560MHz_uart2_m0_115200_v1.21.bin
endef
+define Trusted-Firmware-A/rk3588
+ BUILD_SUBTARGET:=armv8
+ ATF:=rk35/rk3588_bl31_v1.45.elf
+ TPL:=rk35/rk3588_ddr_lp4_2112MHz_lp5_2400MHz_v1.16.bin
+endef
+
TFA_TARGETS:= \
rk3308 \
rk3308-rock-pi-s \
rk3566 \
rk3568 \
- rk3568-e25
+ rk3568-e25 \
+ rk3588
ifeq ($(BUILD_VARIANT),rk3308-rock-pi-s)
TPL_FILE:=rk3308_ddr_589MHz_uart0_m0_v2.07.bin