projects
/
openwrt
/
staging
/
blocktrron.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
355866f
)
optee-os-stm32: add STM32MP157C-DK2 support
author
Thomas Richard
<thomas.richard@bootlin.com>
Wed, 15 Jan 2025 07:27:44 +0000
(08:27 +0100)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Sat, 19 Apr 2025 16:40:58 +0000
(18:40 +0200)
Add entry for STM32MP157C-DK2 and the SCMI variant.
Signed-off-by: Thomas Richard <thomas.richard@bootlin.com>
Link:
https://github.com/openwrt/openwrt/pull/18119
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/boot/optee-os-stm32/Makefile
patch
|
blob
|
history
diff --git
a/package/boot/optee-os-stm32/Makefile
b/package/boot/optee-os-stm32/Makefile
index e0be8e433e52e20c747813549b4ba97ee74ffd1c..c9994f790f3e9555572e1e16a34aa648c31f9997 100644
(file)
--- a/
package/boot/optee-os-stm32/Makefile
+++ b/
package/boot/optee-os-stm32/Makefile
@@
-34,7
+34,22
@@
define Optee-os/stm32mp135f-dk
PLAT_FLAVOR:=135F_DK
endef
-OPTEE_TARGETS := stm32mp135f-dk
+define Optee-os/stm32mp157c-dk2
+ $(call Optee-os/stm32mp1)
+ NAME:=STM32MP157C-DK2
+ PLAT_FLAVOR:=157C_DK2
+endef
+
+define Optee-os/stm32mp157c-dk2-scmi
+ $(call Optee-os/stm32mp1)
+ NAME:=STM32MP157C-DK2 (SCMI)
+ PLAT_FLAVOR:=157C_DK2_SCMI
+endef
+
+OPTEE_TARGETS := \
+ stm32mp135f-dk \
+ stm32mp157c-dk2 \
+ stm32mp157c-dk2-scmi
define Package/optee-os/install/default
endef