projects
/
openwrt
/
staging
/
stintel.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
ddeabc7
)
scripts: ext-toolchain: add support for info.mk in probe_cc
author
Christian Marangi
<ansuelsmth@gmail.com>
Sun, 17 Jul 2022 15:56:36 +0000
(17:56 +0200)
committer
Christian Marangi
<ansuelsmth@gmail.com>
Sun, 24 Jul 2022 17:53:44 +0000
(19:53 +0200)
Openwrt generate info.mk that contains the libc type. For probe_cc check
if the file exist and parse directly it for LIBC type.
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
scripts/ext-toolchain.sh
patch
|
blob
|
history
diff --git
a/scripts/ext-toolchain.sh
b/scripts/ext-toolchain.sh
index 1ef3f42c50a9e4121c54c0bdb0c0ae7b5b3020fe..1f8eca30769a81cf599c439c8466220752f44801 100755
(executable)
--- a/
scripts/ext-toolchain.sh
+++ b/
scripts/ext-toolchain.sh
@@
-463,6
+463,13
@@
probe_cpp() {
}
probe_libc() {
+ if [ -f $TOOLCHAIN/info.mk ]; then
+ LIBC_TYPE=$(grep LIBC_TYPE $TOOLCHAIN/info.mk | sed 's/LIBC_TYPE=//')
+ return 0
+ fi
+
+ echo "Warning! Can't find info.mk, trying to detect with alternative way."
+
if [ -z "$LIBC_TYPE" ]; then
if test_uclibc; then
LIBC_TYPE="uclibc"