Prevent CONFIG_COMPAT_BLUETOOTH_* options from going to compat_autoconf.h
authorLuis R. Rodriguez <lrodriguez@atheros.com>
Tue, 12 Jan 2010 23:39:11 +0000 (15:39 -0800)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Tue, 12 Jan 2010 23:39:11 +0000 (15:39 -0800)
The include/linux/compat_autoconf.h is used to let drivers know of
options we have selected. The scripts used to generate will grep for
all config options on config.mk which start with CONFIG_. By adding
a space we prevent it from adding options.

By preventing it from appearing on compat_autoconf.h it lets us
selectively disable building bluetooth under certain conditions,
which we will do next in a separate patch.

Signed-off-by: Luis R. Rodriguez <lrodriguez@atheros.com>
config.mk

index 8f553c76f45b0214e4cfd9d13f395c6d25168a3d..b8ed05c89fbaab2d5f2dd0f96ddb0cf92d7e78e5 100644 (file)
--- a/config.mk
+++ b/config.mk
@@ -93,8 +93,8 @@ endif
 ifeq ($(CONFIG_BT),y)
 # we'll ignore compiling bluetooth
 else
-CONFIG_COMPAT_BLUETOOTH=y
-CONFIG_COMPAT_BLUETOOTH_MODULES=m
+ CONFIG_COMPAT_BLUETOOTH=y
+ CONFIG_COMPAT_BLUETOOTH_MODULES=m
 endif