projects
/
openwrt
/
staging
/
dangole.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
18f76fb
)
add pkgconfig information for popt library
author
John Crispin
<john@openwrt.org>
Sat, 17 Jan 2015 12:52:28 +0000
(12:52 +0000)
committer
John Crispin
<john@openwrt.org>
Sat, 17 Jan 2015 12:52:28 +0000
(12:52 +0000)
Modify makefile to record pkgconfig information for the popt library.
Signed-off-by: Mike Brady <mikebrady@eircom.net>
SVN-Revision: 43994
package/libs/popt/Makefile
patch
|
blob
|
history
diff --git
a/package/libs/popt/Makefile
b/package/libs/popt/Makefile
index bd2e6e2883da78189bc3786972f27b8183a44835..b31b311513582dd08336896f58162d4fe4c5a54d 100644
(file)
--- a/
package/libs/popt/Makefile
+++ b/
package/libs/popt/Makefile
@@
-45,6
+45,8
@@
define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/include/popt.h $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libpopt.{a,so*} $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/popt.pc $(1)/usr/lib/pkgconfig/
endef
define Package/libpopt/install