projects
/
openwrt
/
staging
/
stintel.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
a3f9b42
)
kernel: modules: package kmod-crypto-essiv
author
Daniel Golle
<daniel@makrotopia.org>
Sun, 11 Sep 2022 13:26:25 +0000
(14:26 +0100)
committer
Daniel Golle
<daniel@makrotopia.org>
Sun, 18 Sep 2022 14:39:41 +0000
(15:39 +0100)
Package kernel module providing ESSIV support for block encryption.
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
(cherry picked from commit
4133102898502c9bb453e8603b6c891aa103bce4
)
package/kernel/linux/modules/crypto.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/crypto.mk
b/package/kernel/linux/modules/crypto.mk
index 441039cdd5dc5bde43b67d038ba52850e84c65ec..3a59d7867110c9038716fedc64206985e6b77c66 100644
(file)
--- a/
package/kernel/linux/modules/crypto.mk
+++ b/
package/kernel/linux/modules/crypto.mk
@@
-237,6
+237,18
@@
endef
$(eval $(call KernelPackage,crypto-echainiv))
+define KernelPackage/crypto-essiv
+ TITLE:=ESSIV support for block encryption
+ DEPENDS:=+kmod-crypto-authenc
+ KCONFIG:=CONFIG_CRYPTO_ESSIV
+ FILES:= $(LINUX_DIR)/crypto/essiv.ko
+ AUTOLOAD:=$(call AutoLoad,10,essiv)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-essiv))
+
+
define KernelPackage/crypto-fcrypt
TITLE:=FCRYPT cipher CryptoAPI module
KCONFIG:=CONFIG_CRYPTO_FCRYPT