ramips: ignore errors from trx utility
authorChristian Marangi <ansuelsmth@gmail.com>
Wed, 30 Oct 2024 13:07:22 +0000 (14:07 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Wed, 30 Oct 2024 13:17:34 +0000 (14:17 +0100)
Ignore errors from trx utility to handle case with image too big.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
target/linux/ramips/image/Makefile

index fdc15aa1efc3ce016c31001f23253cdf61a16e45..569717694345c4c76fb1641a8fd154a79d120540 100644 (file)
@@ -140,7 +140,7 @@ define Build/sign-dlink-ru
 endef
 
 define Build/trx
-       $(STAGING_DIR_HOST)/bin/trx $(1) \
+       -$(STAGING_DIR_HOST)/bin/trx $(1) \
                -o $@ \
                -m $$(($(call exp_units,$(IMAGE_SIZE)))) \
                -f $(IMAGE_KERNEL) \