projects
/
openwrt
/
staging
/
wigyori.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
24d9b50
)
kernel/i2c-i801: fix missing dependency
author
Mieczyslaw Nalewaj
<namiltd@yahoo.com>
Mon, 25 Nov 2024 14:02:00 +0000
(15:02 +0100)
committer
Zoltan HERPAI
<wigyori@uid0.hu>
Tue, 17 Dec 2024 22:28:11 +0000
(23:28 +0100)
Fix missing dependency on kernel 6.12.
Signed-off-by: Mieczyslaw Nalewaj <namiltd@yahoo.com>
package/kernel/linux/modules/i2c.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/i2c.mk
b/package/kernel/linux/modules/i2c.mk
index 8b47628da26c6a6f27182517df010c10859c6d3e..6145dc3077d8d90ac33356b6f2a16589a0d7047e 100644
(file)
--- a/
package/kernel/linux/modules/i2c.mk
+++ b/
package/kernel/linux/modules/i2c.mk
@@
-150,7
+150,7
@@
I2C_I801_MODULES:= \
define KernelPackage/i2c-i801
$(call i2c_defaults,$(I2C_I801_MODULES),59)
TITLE:=Intel I801 and compatible I2C interfaces
- DEPENDS:=@PCI_SUPPORT @TARGET_x86 +kmod-i2c-core +kmod-i2c-smbus
+ DEPENDS:=@PCI_SUPPORT @TARGET_x86 +kmod-i2c-core +kmod-i2c-smbus
+LINUX_6_12:kmod-i2c-mux
endef
define KernelPackage/i2c-i801/description