projects
/
openwrt
/
staging
/
blocktrron.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
784d808
)
build: move the CCACHE_DIR to the build targets so that it doesn't interfere with...
author
Felix Fietkau
<nbd@openwrt.org>
Tue, 15 Mar 2011 19:58:32 +0000
(19:58 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Tue, 15 Mar 2011 19:58:32 +0000
(19:58 +0000)
SVN-Revision: 26181
include/package.mk
patch
|
blob
|
history
rules.mk
patch
|
blob
|
history
diff --git
a/include/package.mk
b/include/package.mk
index 1cf4d64cc9098e6c48b9ffc3c9a8af532ab18e01..2ebd66d119c7fe714123d9d0df708e1324e36f5f 100644
(file)
--- a/
include/package.mk
+++ b/
include/package.mk
@@
-90,6
+90,7
@@
define Build/Exports/Default
$(1) : export CONFIG_SITE:=$$(CONFIG_SITE)
$(1) : export PKG_CONFIG_PATH:=$$(PKG_CONFIG_PATH)
$(1) : export PKG_CONFIG_LIBDIR:=$$(PKG_CONFIG_PATH)
+ $(1) : export CCACHE_DIR:=$(STAGING_DIR)/ccache
endef
Build/Exports=$(Build/Exports/Default)
diff --git
a/rules.mk
b/rules.mk
index c2b0dcaff9becf2789e163125f5ecfd98889f6d8..2d56c436ed20726d36d1d19617c9d21e447cc85a 100644
(file)
--- a/
rules.mk
+++ b/
rules.mk
@@
-178,8
+178,6
@@
INSTALL_DATA:=install -m0644
INSTALL_CONF:=install -m0600
ifneq ($(CONFIG_CCACHE),)
- # FIXME: move this variable to a better location
- export CCACHE_DIR=$(STAGING_DIR)/ccache
TARGET_CC:= ccache $(TARGET_CC)
TARGET_CXX:= ccache $(TARGET_CXX)
endif