projects
/
openwrt
/
staging
/
robimarko.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
48e4708
)
only build bin packages for the selected build variants (same behaviour as with ipkg...
author
Felix Fietkau
<nbd@openwrt.org>
Sat, 15 May 2010 15:57:00 +0000
(15:57 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sat, 15 May 2010 15:57:00 +0000
(15:57 +0000)
SVN-Revision: 21455
include/package-bin.mk
patch
|
blob
|
history
diff --git
a/include/package-bin.mk
b/include/package-bin.mk
index 6ee7aed6217087df154eff60a318fe36c2688512..96c1aeffcfb0b59c1d4811b75288de3a1e28df1d 100644
(file)
--- a/
include/package-bin.mk
+++ b/
include/package-bin.mk
@@
-7,6
+7,7
@@
ifeq ($(DUMP),)
define BuildTarget/bin
+ ifeq ($(if $(VARIANT),$(BUILD_VARIANT)),$(VARIANT))
ifdef Package/$(1)/install
ifneq ($(CONFIG_PACKAGE_$(1))$(SDK)$(DEVELOPER),)
compile: install-bin-$(1)
@@
-16,6
+17,7
@@
ifeq ($(DUMP),)
@echo "WARNING: skipping $(1) -- package not selected"
endif
endif
+ endif
install-bin-$(1): $(STAMP_BUILT)
rm -rf $(BIN_DIR)/$(1)