projects
/
openwrt
/
staging
/
zorun.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
9a22315
)
include: cmake: pass toolchain directory to default root find path as well
author
Jo-Philipp Wich
<jow@openwrt.org>
Wed, 7 Aug 2013 13:54:51 +0000
(13:54 +0000)
committer
Jo-Philipp Wich
<jow@openwrt.org>
Wed, 7 Aug 2013 13:54:51 +0000
(13:54 +0000)
SVN-Revision: 37737
include/cmake.mk
patch
|
blob
|
history
diff --git
a/include/cmake.mk
b/include/cmake.mk
index 64a0654f9685004de625b22279ac58596105cc1b..774632111fbeb26418261149c31e49d5fe24bf94 100644
(file)
--- a/
include/cmake.mk
+++ b/
include/cmake.mk
@@
-48,7
+48,7
@@
define Build/Configure/Default
-DCMAKE_EXE_LINKER_FLAGS:STRING="$(TARGET_LDFLAGS)" \
-DCMAKE_MODULE_LINKER_FLAGS:STRING="$(TARGET_LDFLAGS)" \
-DCMAKE_SHARED_LINKER_FLAGS:STRING="$(TARGET_LDFLAGS)" \
- -DCMAKE_FIND_ROOT_PATH=
$(STAGING_DIR)
\
+ -DCMAKE_FIND_ROOT_PATH=
"$(STAGING_DIR);$(TOOLCHAIN_DIR)"
\
-DCMAKE_FIND_ROOT_PATH_MODE_PROGRAM=BOTH \
-DCMAKE_FIND_ROOT_PATH_MODE_LIBRARY=ONLY \
-DCMAKE_FIND_ROOT_PATH_MODE_INCLUDE=ONLY \