PCI: Add SPDX GPL-2.0 when no license was specified
authorBjorn Helgaas <bhelgaas@google.com>
Fri, 26 Jan 2018 17:45:16 +0000 (11:45 -0600)
committerBjorn Helgaas <bhelgaas@google.com>
Fri, 26 Jan 2018 17:45:16 +0000 (11:45 -0600)
b24413180f56 ("License cleanup: add SPDX GPL-2.0 license identifier to
files with no license") added SPDX GPL-2.0 to several PCI files that
previously contained no license information.

Add SPDX GPL-2.0 to all other PCI files that did not contain any license
information and hence were under the default GPL version 2 license of the
kernel.

Signed-off-by: Bjorn Helgaas <bhelgaas@google.com>
Reviewed-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
33 files changed:
drivers/pci/Kconfig
drivers/pci/access.c
drivers/pci/ats.c
drivers/pci/bus.c
drivers/pci/dwc/Kconfig
drivers/pci/endpoint/Kconfig
drivers/pci/endpoint/Makefile
drivers/pci/endpoint/functions/Kconfig
drivers/pci/endpoint/functions/Makefile
drivers/pci/host-bridge.c
drivers/pci/host/Kconfig
drivers/pci/host/pci-v3-semi.c
drivers/pci/hotplug/Kconfig
drivers/pci/iov.c
drivers/pci/msi.c
drivers/pci/pci-acpi.c
drivers/pci/pci.c
drivers/pci/pcie/Kconfig
drivers/pci/pcie/aer/Kconfig
drivers/pci/pcie/aer/Kconfig.debug
drivers/pci/pcie/portdrv_bus.c
drivers/pci/probe.c
drivers/pci/remove.c
drivers/pci/rom.c
drivers/pci/search.c
drivers/pci/setup-bus.c
drivers/pci/setup-irq.c
drivers/pci/slot.c
drivers/pci/switch/Kconfig
drivers/pci/switch/Makefile
drivers/pci/vpd.c
drivers/pci/xen-pcifront.c
lib/pci_iomap.c

index bda151788f3f723198be6c3401393f3876f5babf..949aa74206cd6236000bfa4ea7a91509e757b40a 100644 (file)
@@ -1,3 +1,4 @@
+# SPDX-License-Identifier: GPL-2.0
 #
 # PCI configuration
 #
index 913d6722ece988463b9850b7e7add11634766091..5a64da3fb0337350a0ad03465bac3ed527d0e7ed 100644 (file)
@@ -1,3 +1,4 @@
+// SPDX-License-Identifier: GPL-2.0
 #include <linux/delay.h>
 #include <linux/pci.h>
 #include <linux/module.h>
index ad8ddbbbf245836f87b6de2d8a0bc20982dc1886..6ad80a1fd5a7a6098ac41b3dbd38bea427dc7839 100644 (file)
@@ -1,3 +1,4 @@
+// SPDX-License-Identifier: GPL-2.0
 /*
  * drivers/pci/ats.c
  *
index bc56cf19afd392c7b3feefa2cf5f070f059ed9e1..30a4d33038bf6c5e142e68b2f12597d85523f54b 100644 (file)
@@ -1,3 +1,4 @@
+// SPDX-License-Identifier: GPL-2.0
 /*
  *     drivers/pci/bus.c
  *
index 113e09440f85c07815654e2eab80f999fc54e6fd..fe1cb56b71f1f1665f2de46115cf6f4d937b57a3 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: GPL-2.0
+
 menu "DesignWare PCI Core Support"
 
 config PCIE_DW
index c09623ca8c3b14b9b522c471fa9ac118c9522106..d1e7e41994323a98ef94214d0e7d16dc35680c4c 100644 (file)
@@ -1,3 +1,4 @@
+# SPDX-License-Identifier: GPL-2.0
 #
 # PCI Endpoint Support
 #
index 1041f80a4645683c4e84bc7095b7aa9675c615f0..95b2fe47e3b06be6ecd210e8d834610021a22470 100644 (file)
@@ -1,3 +1,4 @@
+# SPDX-License-Identifier: GPL-2.0
 #
 # Makefile for PCI Endpoint Support
 #
index 2942066607e0e9a6393139bfab65b5c13f6b09c5..8820d0f7ec77961e654bfeab2ed5a0e892ea76ee 100644 (file)
@@ -1,3 +1,4 @@
+# SPDX-License-Identifier: GPL-2.0
 #
 # PCI Endpoint Functions
 #
index 6d94a48018380bc81a0ed2f7d77e58d51c9b4394..d6fafff080e2a7869c2ad535503815305d061979 100644 (file)
@@ -1,3 +1,4 @@
+# SPDX-License-Identifier: GPL-2.0
 #
 # Makefile for PCI Endpoint Functions
 #
index add66236215c66887fb2f9682d72118a9f786849..ac8d812682962dd4ce23075df550395b36356c90 100644 (file)
@@ -1,3 +1,4 @@
+// SPDX-License-Identifier: GPL-2.0
 /*
  * host bridge related code
  */
index 38d12980db0f0f3358030e419ed86400b7b275c3..a4ed7484d12739bf45adb54803728440257e4f8d 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: GPL-2.0
+
 menu "PCI host controller drivers"
        depends on PCI
 
index 02f6e1e3a421a239403fb6551779ac680560180f..7fef64869d19914a36003db6f8192498b0c0f34d 100644 (file)
@@ -1,3 +1,4 @@
+// SPDX-License-Identifier: GPL-2.0
 /*
  * Support for V3 Semiconductor PCI Local Bus to PCI Bridge
  * Copyright (C) 2017 Linus Walleij <linus.walleij@linaro.org>
index aadce45a9b4a598b94b6c1f8504ee69e2a481d7a..a8f21d051e0c60cf89ab5f05195f9ef965c6c17e 100644 (file)
@@ -1,3 +1,4 @@
+# SPDX-License-Identifier: GPL-2.0
 #
 # PCI Hotplug support
 #
index 6bacb8995e9641dfc0ab98d6a5e9f032bbd7f98e..c533325e8d86155eb9e80e744b1b382da34e56f4 100644 (file)
@@ -1,3 +1,4 @@
+// SPDX-License-Identifier: GPL-2.0
 /*
  * drivers/pci/iov.c
  *
index e066071678580271e68da7d962fa3fccfb69ab45..7f7547d200e40ba572f4c48cc80ae724a626ecdf 100644 (file)
@@ -1,3 +1,4 @@
+// SPDX-License-Identifier: GPL-2.0
 /*
  * File:       msi.c
  * Purpose:    PCI Message Signaled Interrupt (MSI)
index 4708eb9df71b0ebb7548b87e4cb4238a0b900b6a..3b82bb86a203d8609a5e141f6915c60669ee7fc7 100644 (file)
@@ -1,3 +1,4 @@
+// SPDX-License-Identifier: GPL-2.0
 /*
  * File:       pci-acpi.c
  * Purpose:    Provide PCI support in ACPI
index 4a7c6864fdf42f8e720a46bd4c38820a29efa989..50e716b3e2b8fce7fcad393bd438f9281cb1ab9e 100644 (file)
@@ -1,3 +1,4 @@
+// SPDX-License-Identifier: GPL-2.0
 /*
  *     PCI Bus Services, see include/linux/pci.h for further explanation.
  *
index ac53edbc9613cc3a89ecdaf1c88241d0fe824279..6d75a2eb6ecbf70a4f184447adf28d0d8ad7195d 100644 (file)
@@ -1,3 +1,4 @@
+# SPDX-License-Identifier: GPL-2.0
 #
 # PCI Express Port Bus Configuration
 #
index 7d1437b01fdd8f586e705c3842ab4e798de8750f..5a64eb3d6c7a0546a01697a1041f622110df10ff 100644 (file)
@@ -1,3 +1,4 @@
+# SPDX-License-Identifier: GPL-2.0
 #
 # PCI Express Root Port Device AER Configuration
 #
index 9142949734f541630a7cb7a4512be15f6986f0fc..67e02174b65b7ce9693b47450e9e698b9acdf24a 100644 (file)
@@ -1,3 +1,4 @@
+# SPDX-License-Identifier: GPL-2.0
 #
 # PCI Express Root Port Device AER Debug Configuration
 #
index 87e79a6ffb5a0da6cc7ac93a7d39d05ce17ae8ad..f0fba552a0e2691d2a3802cacdf3b6e4933cf27a 100644 (file)
@@ -1,3 +1,4 @@
+// SPDX-License-Identifier: GPL-2.0
 /*
  * File:       portdrv_bus.c
  * Purpose:    PCI Express Port Bus Driver's Bus Overloading Functions
index 14e0ea1ff38b3745111ead4fba31a9fc124c1235..3ea2d610d607ebb9c2f879e4436473a38a13614c 100644 (file)
@@ -1,3 +1,4 @@
+// SPDX-License-Identifier: GPL-2.0
 /*
  * probe.c - PCI detection and setup code
  */
index 2fa0dbde36b7ab5a711c1b9b0b24052e286b9010..6f072eae4f7a59a5f7678a6d258bf7fe458e4c43 100644 (file)
@@ -1,3 +1,4 @@
+// SPDX-License-Identifier: GPL-2.0
 #include <linux/pci.h>
 #include <linux/module.h>
 #include <linux/pci-aspm.h>
index 1f5e6af96c834307c8acf0afcab4b8b437fb3226..9ba3fa841eb02fd2970201200d38bb607a516637 100644 (file)
@@ -1,3 +1,4 @@
+// SPDX-License-Identifier: GPL-2.0
 /*
  * drivers/pci/rom.c
  *
index 4c6044ad7368acbe617fbd6bd90bfb359f29032a..bc1e023f13530d588f8d75eb826b8b23f0dd35e9 100644 (file)
@@ -1,3 +1,4 @@
+// SPDX-License-Identifier: GPL-2.0
 /*
  *     PCI searching functions.
  *
index b1ad466199ad74d207b0c46c01c0d0d19adde44a..0a26648f1712ee2095c4271e70c72995a1c8530c 100644 (file)
@@ -1,3 +1,4 @@
+// SPDX-License-Identifier: GPL-2.0
 /*
  *     drivers/pci/setup-bus.c
  *
index 86106c44ce94547422647d4fa78946d147e24fa5..9c8d81b3cf82a2ab270f971311d654eab431441d 100644 (file)
@@ -1,3 +1,4 @@
+// SPDX-License-Identifier: GPL-2.0
 /*
  *     drivers/pci/setup-irq.c
  *
index e42909524deed903e098cc2cade5a21626181f70..d10f556dc03ea9fd546a8b1a2c656d7cb8403b31 100644 (file)
@@ -1,3 +1,4 @@
+// SPDX-License-Identifier: GPL-2.0
 /*
  * drivers/pci/slot.c
  * Copyright (C) 2006 Matthew Wilcox <matthew@wil.cx>
index 4c49648e0646f047446f6b1429ad82f45f1fd061..aee28a5bb98f92755f99a2035045370ccf10595c 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: GPL-2.0
+
 menu "PCI switch controller drivers"
        depends on PCI
 
index 37d8cfb03f3f87156c7ae29790d4d1aa3b18ca28..acd56d3b4a35938979acf02423dc0cc115338513 100644 (file)
@@ -1 +1,2 @@
+# SPDX-License-Identifier: GPL-2.0
 obj-$(CONFIG_PCI_SW_SWITCHTEC) += switchtec.o
index 39b79070335db7f0a5ae040b083bdc457c2f0f44..70fba57d610326f684ea2b97b07369cd4e8678a6 100644 (file)
@@ -1,3 +1,4 @@
+// SPDX-License-Identifier: GPL-2.0
 /*
  * File:       vpd.c
  * Purpose:    Provide PCI VPD support
index 8fc2e9532575679ab60724201fa0181b1679c809..82fe8526ac904b9d53ccbb415603ab0fcfdd1eff 100644 (file)
@@ -1,3 +1,4 @@
+// SPDX-License-Identifier: GPL-2.0
 /*
  * Xen PCI Frontend.
  *
index c10fba461454fc8efe03b9fb46719ee80dad6a47..2d3eb1cb73b8f5b9ee3307e8700d64379cdea19d 100644 (file)
@@ -1,3 +1,4 @@
+// SPDX-License-Identifier: GPL-2.0
 /*
  * Implement the default iomap interfaces
  *