projects
/
openwrt
/
staging
/
xback.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
484a793
)
ltq-ifxos: only attempt to build if the lantiq target is selected (fixes #9035)
author
Felix Fietkau
<nbd@openwrt.org>
Sun, 13 Mar 2011 18:45:27 +0000
(18:45 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sun, 13 Mar 2011 18:45:27 +0000
(18:45 +0000)
SVN-Revision: 26132
package/ltq-ifxos/Makefile
patch
|
blob
|
history
diff --git
a/package/ltq-ifxos/Makefile
b/package/ltq-ifxos/Makefile
index 518c90fd6fc395dcb32472be1fbe159de23736a6..c947404b998870c04813f55d8766c0d72ae028ba 100644
(file)
--- a/
package/ltq-ifxos/Makefile
+++ b/
package/ltq-ifxos/Makefile
@@
-39,11
+39,13
@@
define Build/Configure
$(call Build/Configure/Default)
endef
-define Build/InstallDev
+ifdef CONFIG_TARGET_lantiq
+ define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/{lib,include/ifxos}
$(CP) $(PKG_BUILD_DIR)/src/include/* $(1)/usr/include/ifxos
mkdir -p $(1)/usr/lib
$(CP) $(PKG_BUILD_DIR)/src/libifxos.a $(1)/usr/lib/libifxos.a
-endef
+ endef
+endif
$(eval $(call KernelPackage,ltq-ifxos))