dev->flags |= IFF_BROADCAST | IFF_MULTICAST;
--- a/drivers/net/wireless/libertas/mesh.c
+++ b/drivers/net/wireless/libertas/mesh.c
-@@ -985,7 +985,7 @@
+@@ -985,7 +985,7 @@ static int lbs_add_mesh(struct lbs_priva
mesh_dev->ml_priv = priv;
priv->mesh_dev = mesh_dev;
--- a/net/wireless/nl80211.c
+++ b/net/wireless/nl80211.c
-@@ -4700,7 +4700,9 @@ static int nl80211_wiphy_netns(struct sk
+@@ -4714,7 +4714,9 @@ static int nl80211_wiphy_netns(struct sk
if (!net_eq(wiphy_net(&rdev->wiphy), net))
err = cfg80211_switch_netns(rdev, net);
if (sysfs_create_link(&dev->dev.kobj, &rdev->wiphy.dev.kobj,
"phy80211")) {
-@@ -982,6 +988,7 @@ static struct notifier_block cfg80211_ne
+@@ -983,6 +989,7 @@ static struct notifier_block cfg80211_ne
.notifier_call = cfg80211_netdev_notifier_call,
};
static void __net_exit cfg80211_pernet_exit(struct net *net)
{
struct cfg80211_registered_device *rdev;
-@@ -999,14 +1006,17 @@ static void __net_exit cfg80211_pernet_e
+@@ -1000,14 +1007,17 @@ static void __net_exit cfg80211_pernet_e
static struct pernet_operations cfg80211_pernet_ops = {
.exit = cfg80211_pernet_exit,
};
err = wiphy_sysfs_init();
if (err)
-@@ -1041,8 +1051,10 @@ out_fail_nl80211:
+@@ -1042,8 +1052,10 @@ out_fail_nl80211:
out_fail_notifier:
wiphy_sysfs_exit();
out_fail_sysfs:
return err;
}
subsys_initcall(cfg80211_init);
-@@ -1054,7 +1066,9 @@ static void __exit cfg80211_exit(void)
+@@ -1055,7 +1067,9 @@ static void __exit cfg80211_exit(void)
unregister_netdevice_notifier(&cfg80211_netdev_notifier);
wiphy_sysfs_exit();
regulatory_exit();
static int __init p54u_init(void)
--- a/drivers/net/wireless/ath/ath9k/hif_usb.c
+++ b/drivers/net/wireless/ath/ath9k/hif_usb.c
-@@ -1307,7 +1307,9 @@ static struct usb_driver ath9k_hif_usb_d
+@@ -1310,7 +1310,9 @@ static struct usb_driver ath9k_hif_usb_d
.reset_resume = ath9k_hif_usb_resume,
#endif
.id_table = ath9k_hif_usb_ids,
--- a/drivers/net/wireless/rtlwifi/base.c
+++ b/drivers/net/wireless/rtlwifi/base.c
-@@ -28,6 +28,7 @@
- *****************************************************************************/
+@@ -30,6 +30,7 @@
+ #define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
#include <linux/ip.h>
+#include <linux/in.h>
--- a/drivers/net/atl1c/atl1c_main.c
+++ b/drivers/net/atl1c/atl1c_main.c
-@@ -2880,6 +2880,9 @@ static struct pci_error_handlers atl1c_e
+@@ -2898,6 +2898,9 @@ static struct pci_error_handlers atl1c_e
static SIMPLE_DEV_PM_OPS(atl1c_pm_ops, atl1c_suspend, atl1c_resume);
static struct pci_driver atl1c_driver = {
.name = atl1c_driver_name,
.id_table = atl1c_pci_tbl,
-@@ -2887,7 +2890,12 @@ static struct pci_driver atl1c_driver =
+@@ -2905,7 +2908,12 @@ static struct pci_driver atl1c_driver =
.remove = __devexit_p(atl1c_remove),
.shutdown = atl1c_shutdown,
.err_handler = &atl1c_err_handler,
/*
--- a/drivers/net/atlx/atl1.c
+++ b/drivers/net/atlx/atl1.c
-@@ -2837,6 +2837,9 @@ static int atl1_resume(struct device *de
+@@ -2836,6 +2836,9 @@ static int atl1_resume(struct device *de
return 0;
}
static SIMPLE_DEV_PM_OPS(atl1_pm_ops, atl1_suspend, atl1_resume);
#define ATL1_PM_OPS (&atl1_pm_ops)
-@@ -3104,7 +3107,12 @@ static struct pci_driver atl1_driver = {
+@@ -3105,7 +3108,12 @@ static struct pci_driver atl1_driver = {
.probe = atl1_probe,
.remove = __devexit_p(atl1_remove),
.shutdown = atl1_shutdown,
static int __init iwl4965_init(void)
--- a/drivers/net/wireless/iwlwifi/iwl-pci.c
+++ b/drivers/net/wireless/iwlwifi/iwl-pci.c
-@@ -528,6 +528,9 @@ static int iwl_pci_resume(struct device
+@@ -537,6 +537,9 @@ static int iwl_pci_resume(struct device
static SIMPLE_DEV_PM_OPS(iwl_dev_pm_ops, iwl_pci_suspend, iwl_pci_resume);
#define IWL_PM_OPS (&iwl_dev_pm_ops)
#else
-@@ -541,7 +544,12 @@ static struct pci_driver iwl_pci_driver
+@@ -550,7 +553,12 @@ static struct pci_driver iwl_pci_driver
.id_table = iwl_hw_card_ids,
.probe = iwl_pci_probe,
.remove = __devexit_p(iwl_pci_remove),
for (i = 0; i < adapter->priv_num; i++)
if ((GET_BSS_ROLE(adapter->priv[i]) ==
-@@ -144,6 +146,7 @@ mwifiex_sdio_remove(struct sdio_func *fu
+@@ -147,6 +149,7 @@ mwifiex_sdio_remove(struct sdio_func *fu
kfree(card);
}
/*
* SDIO suspend.
*
-@@ -251,6 +254,7 @@ static int mwifiex_sdio_resume(struct de
+@@ -254,6 +257,7 @@ static int mwifiex_sdio_resume(struct de
return 0;
}
/* Device ID for SD8787 */
#define SDIO_DEVICE_ID_MARVELL_8787 (0x9119)
-@@ -263,10 +267,12 @@ static const struct sdio_device_id mwifi
+@@ -266,10 +270,12 @@ static const struct sdio_device_id mwifi
MODULE_DEVICE_TABLE(sdio, mwifiex_ids);
static struct sdio_driver mwifiex_sdio = {
.name = "mwifiex_sdio",
-@@ -275,7 +281,9 @@ static struct sdio_driver mwifiex_sdio =
+@@ -278,7 +284,9 @@ static struct sdio_driver mwifiex_sdio =
.remove = mwifiex_sdio_remove,
.drv = {
.owner = THIS_MODULE,
ntype == NL80211_IFTYPE_P2P_CLIENT))
--- a/net/wireless/nl80211.c
+++ b/net/wireless/nl80211.c
-@@ -1513,7 +1513,7 @@ static int nl80211_valid_4addr(struct cf
+@@ -1514,7 +1514,7 @@ static int nl80211_valid_4addr(struct cf
enum nl80211_iftype iftype)
{
if (!use_4addr) {
spin_unlock_bh(&sta->lock);
--- a/net/mac80211/work.c
+++ b/net/mac80211/work.c
-@@ -65,10 +65,25 @@ static void run_again(struct ieee80211_l
+@@ -66,10 +66,25 @@ static void run_again(struct ieee80211_l
mod_timer(&local->work_timer, timeout);
}
--- a/net/wireless/nl80211.c
+++ b/net/wireless/nl80211.c
-@@ -3767,7 +3767,9 @@ static int nl80211_dump_scan(struct sk_b
+@@ -3794,7 +3794,9 @@ static int nl80211_dump_scan(struct sk_b
spin_lock_bh(&rdev->bss_lock);
cfg80211_bss_expire(rdev);
--- a/drivers/misc/eeprom/Makefile
+++ b/drivers/misc/eeprom/Makefile
-@@ -1,5 +1 @@
+@@ -1,7 +1,3 @@
-obj-$(CONFIG_EEPROM_AT24) += at24.o
-obj-$(CONFIG_EEPROM_AT25) += at25.o
-obj-$(CONFIG_EEPROM_LEGACY) += eeprom.o
-obj-$(CONFIG_EEPROM_MAX6875) += max6875.o
obj-$(CONFIG_EEPROM_93CX6) += eeprom_93cx6.o
+ obj-$(CONFIG_EEPROM_93XX46) += eeprom_93xx46.o
+ obj-$(CONFIG_EEPROM_DIGSY_MTC_CFG) += digsy_mtc_eeprom.o
--- a/drivers/net/usb/Makefile
+++ b/drivers/net/usb/Makefile
@@ -2,31 +2,7 @@