openwrt-keyring: apk: use just snapshot key explicitly main master
authorPetr Štetiar <ynezz@true.cz>
Mon, 4 Nov 2024 09:04:04 +0000 (09:04 +0000)
committerRobert Marko <robimarko@gmail.com>
Mon, 25 Nov 2024 11:20:59 +0000 (12:20 +0100)
Currently we're going to ship all the apk keys in the keyring, but the
preference is to ship and use single release/branch specific key so lets
use openwrt-snapshots.pem for apk explicitly as well.

Fixes: 2cea05002489 ("openwrt-keyring: add apk public key for signing of package indexes")
Signed-off-by: Petr Štetiar <ynezz@true.cz>
Link: https://github.com/openwrt/openwrt/pull/16852
Signed-off-by: Robert Marko <robimarko@gmail.com>
package/system/openwrt-keyring/Makefile

index 029463817b85ddeebd8e694cbf802b6be042a4b7..7f237ed9fa0c1ace8017a352681a087e523b01c7 100644 (file)
@@ -33,7 +33,7 @@ Build/Compile=
 ifneq ($(CONFIG_USE_APK),)
 define Package/openwrt-keyring/install
        $(INSTALL_DIR) $(1)/etc/apk/keys/
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/apk/*.pem $(1)/etc/apk/keys/
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/apk/openwrt-snapshots.pem $(1)/etc/apk/keys/
 endef
 else
 define Package/openwrt-keyring/install