mbim: add delegate option support
authorChen Minqiang <ptpt52@gmail.com>
Wed, 15 May 2024 14:43:03 +0000 (22:43 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 22 Sep 2024 21:43:08 +0000 (23:43 +0200)
Ipv6 delegate option is not respected by proto mbim
this add support for it.

Signed-off-by: Chen Minqiang <ptpt52@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/15508
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/network/utils/umbim/Makefile
package/network/utils/umbim/files/lib/netifd/proto/mbim.sh

index 5b0a5a8f7d11b9841ec28315eda03909b5745715..39c30d71c4f3f8504dd8fea8ac383b12bd9a44e2 100644 (file)
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=umbim
-PKG_RELEASE:=24
+PKG_RELEASE:=25
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/umbim.git
index f2d4c436e882419d1d81b8f64459f3fd06bea9f4..75b914e8aac1ef487201b96f2df1f065da1016b5 100755 (executable)
@@ -23,6 +23,7 @@ proto_mbim_init_config() {
        proto_config_add_string dhcp
        proto_config_add_string dhcpv6
        proto_config_add_boolean sourcefilter
+       proto_config_add_boolean delegate
        proto_config_add_string pdptype
        proto_config_add_int mtu
        proto_config_add_defaults
@@ -48,7 +49,7 @@ _proto_mbim_setup() {
        local device apn pincode delay auth username password allow_roaming allow_partner
        local dhcp dhcpv6 pdptype ip4table ip6table mtu $PROTO_DEFAULT_OPTIONS
        json_get_vars device apn pincode delay auth username password allow_roaming allow_partner
-       json_get_vars dhcp dhcpv6 sourcefilter pdptype ip4table ip6table mtu $PROTO_DEFAULT_OPTIONS
+       json_get_vars dhcp dhcpv6 sourcefilter delegate pdptype ip4table ip6table mtu $PROTO_DEFAULT_OPTIONS
 
        [ ! -e /proc/sys/net/ipv6 ] && ipv6=0 || json_get_var ipv6 ipv6
 
@@ -264,6 +265,7 @@ _proto_mbim_setup() {
                        echo "mbim[$$]" "Starting DHCPv6 on $ifname"
                        json_add_string proto "dhcpv6"
                        json_add_string extendprefix 1
+                       [ "$delegate" = "0" ] && json_add_boolean delegate "0"
                        [ "$sourcefilter" = "0" ] && json_add_boolean sourcefilter "0"
                fi