build: fix defconfig usage
authorJohannes Berg <johannes@sipsolutions.net>
Wed, 3 Apr 2013 22:24:56 +0000 (00:24 +0200)
committerJohannes Berg <johannes@sipsolutions.net>
Wed, 3 Apr 2013 22:24:56 +0000 (00:24 +0200)
The make target vs. filename got confusing and the
invocation of the conf program was wrong as well;
fix both issues.

Signed-off-by: Johannes Berg <johannes@sipsolutions.net>
backport/Makefile.real

index 0a20a66d8ab6f762d45d73d9b5cbcbcb1de301f8..3536fe2e4737b64e25d56d8d2e9582437220a9c5 100644 (file)
@@ -22,13 +22,13 @@ alldefconfig randconfig:
        @$(MAKE) -C kconfig conf
        @./kconfig/conf --$@ Kconfig
 
-.PHONY: defconfig
-defconfig:
+.PHONY: usedefconfig
+usedefconfig:
        @$(MAKE) -C kconfig conf
-       @./kconfig/conf --defconfig defconfig
+       @./kconfig/conf --defconfig=defconfig Kconfig
 
 .config:
-       @test -f defconfig && (yes '' | $(MAKE) alldefconfig) || (      \
+       @test -f defconfig && (yes '' | $(MAKE) usedefconfig) || (      \
        echo "/--------------"                                          ;\
        echo "| Your backport package isn't configured, please configure it" ;\
        echo "| using one of the following options:"                    ;\