projects
/
openwrt
/
staging
/
stintel.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
93372a3
)
iproute2: fix build errors with newer versions of eglibc
author
Felix Fietkau
<nbd@openwrt.org>
Thu, 7 Jun 2012 12:37:49 +0000
(12:37 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Thu, 7 Jun 2012 12:37:49 +0000
(12:37 +0000)
SVN-Revision: 32103
package/iproute2/Makefile
patch
|
blob
|
history
diff --git
a/package/iproute2/Makefile
b/package/iproute2/Makefile
index 640b5658fd40e4e081f0a3be37acf2770c205b62..80681f5577d17c91125ea4674e2161cf51731ae2 100644
(file)
--- a/
package/iproute2/Makefile
+++ b/
package/iproute2/Makefile
@@
-63,6
+63,12
@@
define Build/Configure
> $(PKG_BUILD_DIR)/include/SNAPSHOT.h
endef
+ifdef CONFIG_USE_EGLIBC
+ ifndef CONFIG_EGLIBC_VERSION_2_13
+ TARGET_CFLAGS += -DHAVE_SETNS
+ endif
+endif
+
MAKE_FLAGS += \
EXTRA_CCOPTS="$(TARGET_CFLAGS) -I../include -I$(STAGING_DIR)/usr/include/libnl-tiny" \
KERNEL_INCLUDE="$(LINUX_DIR)/include" \