linux-firmware: move firmware file for mt7601u
authorDaniel Golle <daniel@makrotopia.org>
Mon, 15 May 2023 19:56:27 +0000 (21:56 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 27 May 2023 20:05:14 +0000 (22:05 +0200)
The firmware file for mt7601u (MediaTek MT7601U Wireless MACs) has
been moved to the mediatek/ folder by commit
 8451c2b1 mt76xx: Move the old Mediatek WiFi firmware to mediatek

Address this by updating the location of the firmware file in our
linux-firmware Makefile generating the mt7601u-firmware package.

All other MediaTek Wi-Fi firmware files are supplied by OpenWrt's
own repository rather than being taken from linux-firmware.

Fixes: d53fe5d9ce ("linux-firmware: update to 20230515")
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
(cherry picked from commit d26ecbcf95e2c2ecf5380fdee733c6b46276e265)

package/firmware/linux-firmware/mediatek.mk

index 18677bc748d18b2add20f6f1c199b1322876888f..77f3365f275ec938cac56249aec2d75f3dd0d37d 100644 (file)
@@ -1,9 +1,9 @@
 Package/mt7601u-firmware = $(call Package/firmware-default,MediaTek MT7601U firmware)
 define Package/mt7601u-firmware/install
-       $(INSTALL_DIR) $(1)/lib/firmware
+       $(INSTALL_DIR) $(1)/lib/firmware/mediatek
        $(INSTALL_DATA) \
-               $(PKG_BUILD_DIR)/mt7601u.bin \
-               $(1)/lib/firmware
+               $(PKG_BUILD_DIR)/mediatek/mt7601u.bin \
+               $(1)/lib/firmware/mediatek
 endef
 $(eval $(call BuildPackage,mt7601u-firmware))