drm/i915: make intel_guc_fwif.h self-contained
authorJani Nikula <jani.nikula@intel.com>
Wed, 26 Jun 2019 14:40:16 +0000 (17:40 +0300)
committerJani Nikula <jani.nikula@intel.com>
Thu, 27 Jun 2019 07:50:42 +0000 (10:50 +0300)
Add the minimal includes/declarations to make the header self-contained,
and ensure it stays that way.

Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>
Signed-off-by: Jani Nikula <jani.nikula@intel.com>
Link: https://patchwork.freedesktop.org/patch/msgid/20190626144020.2155-10-jani.nikula@intel.com
drivers/gpu/drm/i915/Makefile.header-test
drivers/gpu/drm/i915/intel_guc_fwif.h

index b296be256913e67eba33bcdac0e3dad1f7ba842c..583fe76f2cdbfd060c26e086abc7832f23ba4752 100644 (file)
@@ -20,6 +20,7 @@ header_test := \
        intel_csr.h \
        intel_drv.h \
        intel_guc_ct.h \
+       intel_guc_fwif.h \
        intel_pm.h \
        intel_runtime_pm.h \
        intel_sideband.h \
index f55f3bc8524d5c7abe4f583c1e3963c841a85128..92bd7ffb5b10f5a7104877f7c9aec5fa794b241f 100644 (file)
 #ifndef _INTEL_GUC_FWIF_H
 #define _INTEL_GUC_FWIF_H
 
+#include <linux/bits.h>
+#include <linux/compiler.h>
+#include <linux/types.h>
+
 #define GUC_CLIENT_PRIORITY_KMD_HIGH   0
 #define GUC_CLIENT_PRIORITY_HIGH       1
 #define GUC_CLIENT_PRIORITY_KMD_NORMAL 2