projects
/
openwrt
/
staging
/
rmilecki.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
1b55cf1
)
make cvs checkouts more flexible. packages must now specify either -r <tag> or -D...
author
Felix Fietkau
<nbd@openwrt.org>
Thu, 19 Feb 2009 17:16:25 +0000
(17:16 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Thu, 19 Feb 2009 17:16:25 +0000
(17:16 +0000)
SVN-Revision: 14566
include/download.mk
patch
|
blob
|
history
diff --git
a/include/download.mk
b/include/download.mk
index 7a4d90da98ab8bc4e23cf4a39b98101d69ed708e..0a2dd3c03fcfd99efec0249550ae85805cde7c42 100644
(file)
--- a/
include/download.mk
+++ b/
include/download.mk
@@
-53,7
+53,7
@@
define DownloadMethod/cvs
cd $(TMP_DIR)/dl && \
rm -rf $(SUBDIR) && \
[ \! -d $(SUBDIR) ] && \
- cvs -d $(URL) co
-r
$(VERSION) $(SUBDIR) && \
+ cvs -d $(URL) co $(VERSION) $(SUBDIR) && \
find $(SUBDIR) -name CVS | xargs rm -rf && \
echo "Packing checkout..." && \
$(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \