projects
/
openwrt
/
svn-archive
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
3a22d8e
)
fix rb532 squashfs support (patch by Jens Muecke)
author
Felix Fietkau
<nbd@openwrt.org>
Mon, 11 Jun 2007 22:58:44 +0000
(22:58 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Mon, 11 Jun 2007 22:58:44 +0000
(22:58 +0000)
SVN-Revision: 7577
target/linux/rb532-2.6/image/Makefile
patch
|
blob
|
history
diff --git
a/target/linux/rb532-2.6/image/Makefile
b/target/linux/rb532-2.6/image/Makefile
index 149a7e27344cb881e566ca90cab34b9c4fca1767..f53c5e4ac3779dee4dd947af9253a2b7f24e9811 100644
(file)
--- a/
target/linux/rb532-2.6/image/Makefile
+++ b/
target/linux/rb532-2.6/image/Makefile
@@
-49,6
+49,10
@@
define Image/cmdline/ext2
root=/dev/cfa2 rootfstype=ext2 init=/etc/preinit
endef
+define Image/cmdline/squashfs
+root=/dev/cfa2 rootfstype=squashfs init=/etc/preinit
+endef
+
define Image/Build
$(STAGING_DIR)/bin/patch-cmdline $(KDIR)/vmlinux.elf '$(strip $(call Image/cmdline/$(1))) '
./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin 4 $(KDIR)/vmlinux.elf $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)