build: apk: Remove /run/apk/db.lock
authorHauke Mehrtens <hauke@hauke-m.de>
Thu, 14 Nov 2024 21:57:02 +0000 (22:57 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Sat, 16 Nov 2024 13:22:22 +0000 (14:22 +0100)
Do not add the file /run/apk/db.lock to the root file system. The /run
folder should be on a tmpfs.

At runtime we should make /run point to a tmpfs. At build time we should
just remove the folder.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Link: https://github.com/openwrt/openwrt/pull/16961
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
package/Makefile

index 2c7cd588793b628fb5595f70eca387745848fbe7..3c6621b81c3c13112bab39e2d9789cd616262142 100644 (file)
@@ -101,6 +101,7 @@ ifneq ($(CONFIG_USE_APK),)
        $(call apk,$(TARGET_DIR)) add --no-cache --initdb --no-scripts --arch $(ARCH_PACKAGES) \
                --repositories-file /dev/null --repository file://$(PACKAGE_DIR_ALL)/packages.adb \
                $$(cat $(TMP_DIR)/apk_install_list)
+       rm -rf $(TARGET_DIR)/run
 else
        $(file >$(TMP_DIR)/opkg_install_list,\
          $(call opkg_package_files,\