octeon: ubnt-usg: add board name to supported devices
authorEric Fahlgren <ericfahlgren@gmail.com>
Sun, 26 Jan 2025 17:25:13 +0000 (09:25 -0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 27 Jan 2025 01:09:46 +0000 (02:09 +0100)
The on-device board name reported by 'ubus call system board' is not present
in the generated profiles.json.  This results in upgrade tools being unable
to match the image with the proper device.  Let's add a 'SUPPORTED_DEVICES'
entry for the board name to fix this.

Links: https://forum.openwrt.org/t/owut-openwrt-upgrade-tool/200035/441
Links: https://github.com/openwrt/openwrt/commit/2a07270180ed0e295d854d6e9e59c78c40549efc
Signed-off-by: Eric Fahlgren <ericfahlgren@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/17736
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/octeon/image/Makefile

index f00e87c52016741ee5c540790494007f81d073e1..dec04809150aeef56b9fa39f3041eb49fdffd4ec 100644 (file)
@@ -92,6 +92,7 @@ define Device/ubnt_unifi-usg
   DEVICE_PACKAGES += kmod-gpio-button-hotplug kmod-leds-gpio
   DEVICE_DTS := cn5020_ubnt_usg
   KERNEL += | append-dtb-to-elf
+  SUPPORTED_DEVICES += ubnt,usg
 endef
 TARGET_DEVICES += ubnt_unifi-usg