projects
/
openwrt
/
staging
/
nbd.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
325e53f
)
ramips: fix image recipe for ASUS RT-N56U
author
Shiji Yang
<yangshiji66@qq.com>
Sat, 6 Jul 2024 10:27:19 +0000
(18:27 +0800)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Sat, 13 Jul 2024 12:30:42 +0000
(14:30 +0200)
The OpenWrt image metadata includes checksum validation. Therefore,
it must be generated at the end.
Fixes: https://github.com/openwrt/openwrt/issues/9045
Fixes: https://github.com/openwrt/openwrt/issues/13674
Link:
https://patchwork.ozlabs.org/project/openwrt/patch/TYCP286MB08952FAACDFA234C5E052131BCD82@TYCP286MB0895.JPNP286.PROD.OUTLOOK.COM/
Signed-off-by: Shiji Yang <yangshiji66@qq.com>
target/linux/ramips/image/rt3883.mk
patch
|
blob
|
history
diff --git
a/target/linux/ramips/image/rt3883.mk
b/target/linux/ramips/image/rt3883.mk
index 04300992965c73fd7e37cef591282057180072cf..1728f8444438e7991121ff639ada29c0edb9c010 100644
(file)
--- a/
target/linux/ramips/image/rt3883.mk
+++ b/
target/linux/ramips/image/rt3883.mk
@@
-8,7
+8,8
@@
endef
define Device/asus_rt-n56u
SOC := rt3662
IMAGE_SIZE := 7872k
- IMAGE/sysupgrade.bin += | mkrtn56uimg -s
+ IMAGE/sysupgrade.bin := $$(sysupgrade_bin) | check-size | \
+ mkrtn56uimg -s | append-metadata
DEVICE_VENDOR := ASUS
DEVICE_MODEL := RT-N56U
DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2