packages/tor{,-alpha}: use new service functions, move user/group creation from posti...
authorNicolas Thill <nico@openwrt.org>
Wed, 9 Nov 2011 23:17:24 +0000 (23:17 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 9 Nov 2011 23:17:24 +0000 (23:17 +0000)
SVN-Revision: 28902

net/tor-alpha/Makefile
net/tor-alpha/files/tor.init
net/tor-alpha/patches/001-torrc.patch
net/tor/Makefile
net/tor/files/tor.init
net/tor/patches/001-torrc.patch

index 6897ae6fdfe43531098d0c0f301e15ccfe2fc996..8873972fcd2d56e85cf53d07f4dc954e3d080680 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tor-alpha
 PKG_VERSION:=0.2.3.5-alpha
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=tor-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://www.torproject.org/dist \
@@ -73,41 +73,6 @@ define Package/tor-alpha/conffiles
 /etc/tor/torrc
 endef
 
-define Package/tor-alpha/postinst
-#!/bin/sh
-
-name=tor
-id=52
-
-# do not change below
-# # check if we are on real system
-if [ -z "$${IPKG_INSTROOT}" ]; then
-        # create copies of passwd and group, if we use squashfs
-        rootfs=`mount |awk '/root/ { print $$5 }'`
-        if [ "$$rootfs" = "squashfs" ]; then
-                if [ -h /etc/group ]; then
-                        rm /etc/group
-                        cp /rom/etc/group /etc/group
-                fi
-                if [ -h /etc/passwd ]; then
-                        rm /etc/passwd
-                        cp /rom/etc/passwd /etc/passwd
-                fi
-        fi
-fi
-
-echo ""
-if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/group)" ]; then
-        echo "adding group $$name to /etc/group"
-        echo "$${name}:x:$${id}:" >> $${IPKG_INSTROOT}/etc/group
-fi
-
-if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then
-        echo "adding user $$name to /etc/passwd"
-        echo "$${name}:x:$${id}:$${id}:$${name}:/tmp/.$${name}:/bin/false" >> $${IPKG_INSTROOT}/etc/passwd
-fi
-endef
-
 CONFIGURE_ARGS += \
        --with-libevent-dir="$(STAGING_DIR)/usr" \
        --with-ssl-dir="$(STAGING_DIR)/usr" \
index 40d4ecf0a1f98b1fd93969fa6f009fa6272835f2..42eff1ae71af041a05217a93111048fb678f9169 100644 (file)
@@ -1,26 +1,29 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
+
 START=50
 
-BIN=tor
-DEFAULT=/etc/default/$BIN
-LOG_D=/var/log/$BIN
-LIB_D=/var/lib/$BIN
-RUN_D=/var/run
-PID_F=$RUN_D/$BIN.pid
-RUN_USER=$BIN
-RUN_GROUP=$BIN
+SERVICE_PID_FILE=/var/run/tor/tor.pid
 
 start() {
-       [ -f $DEFAULT ] && . $DEFAULT
-       [ -d $LOG_D ] || ( mkdir -m 0755 -p $LOG_D && chown $RUN_USER:$RUN_GROUP $LOG_D )
-       [ -d $LIB_D ] || ( mkdir -m 0700 -p $LIB_D && chown $RUN_USER:$RUN_GROUP $LIB_D )
-       [ -d $RUN_D ] || mkdir -p $RUN_D
-       [ -f $PID_F ] || ( touch $PID_F && chown $RUN_USER:$RUN_GROUP $PID_F )
-       $BIN $OPTIONS
+       user_exists tor 52 || user_add tor 52
+       group_exists tor 52 || group_add tor 52
+       [ -d /var/run/tor ] || {
+               mkdir -m 0755 -p /var/run/tor
+               chown tor:tor /var/run/tor
+       }
+       [ -d /var/lib/tor ] || {
+               mkdir -m 0755 -p /var/lib/tor
+               chmod 0700 /var/lib/tor
+               chown tor:tor /var/lib/tor
+       }
+       [ -d /var/log/tor ] || {
+               mkdir -m 0755 -p /var/log/tor
+               chown tor:tor /var/log/tor
+       }
+       service_start /usr/sbin/tor
 }
 
 stop() {
-       [ -f $PID_F ] && kill $(cat $PID_F)
+       service_stop /usr/sbin/tor
 }
-
index a390a6e2d816ba7e362ba4aa2d8dcc8dc15080cd..d5e52709d9a007cb2f1782e5428f4900c0133831 100644 (file)
@@ -19,4 +19,4 @@
  #ExitPolicy reject *:*
  
 +User tor
-+PidFile @LOCALSTATEDIR@/run/tor.pid
++PidFile @LOCALSTATEDIR@/run/tor/tor.pid
index f87ab2615a439caf9e16cd4ecaf0552bd2bf027b..b1dc1730d1361e854e6341ac5f44e728cf04974e 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tor
 PKG_VERSION:=0.2.2.34
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://www.torproject.org/dist \
@@ -50,41 +50,6 @@ define Package/tor/conffiles
 /etc/tor/torrc
 endef
 
-define Package/tor/postinst
-#!/bin/sh
-
-name=tor
-id=52
-
-# do not change below
-# # check if we are on real system
-if [ -z "$${IPKG_INSTROOT}" ]; then
-        # create copies of passwd and group, if we use squashfs
-        rootfs=`mount |awk '/root/ { print $$5 }'`
-        if [ "$$rootfs" = "squashfs" ]; then
-                if [ -h /etc/group ]; then
-                        rm /etc/group
-                        cp /rom/etc/group /etc/group
-                fi
-                if [ -h /etc/passwd ]; then
-                        rm /etc/passwd
-                        cp /rom/etc/passwd /etc/passwd
-                fi
-        fi
-fi
-
-echo ""
-if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/group)" ]; then
-        echo "adding group $$name to /etc/group"
-        echo "$${name}:x:$${id}:" >> $${IPKG_INSTROOT}/etc/group
-fi
-
-if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then
-        echo "adding user $$name to /etc/passwd"
-        echo "$${name}:x:$${id}:$${id}:$${name}:/tmp/.$${name}:/bin/false" >> $${IPKG_INSTROOT}/etc/passwd
-fi
-endef
-
 CONFIGURE_ARGS += \
        --with-libevent-dir="$(STAGING_DIR)/usr" \
        --with-ssl-dir="$(STAGING_DIR)/usr" \
index 40d4ecf0a1f98b1fd93969fa6f009fa6272835f2..42eff1ae71af041a05217a93111048fb678f9169 100644 (file)
@@ -1,26 +1,29 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
+
 START=50
 
-BIN=tor
-DEFAULT=/etc/default/$BIN
-LOG_D=/var/log/$BIN
-LIB_D=/var/lib/$BIN
-RUN_D=/var/run
-PID_F=$RUN_D/$BIN.pid
-RUN_USER=$BIN
-RUN_GROUP=$BIN
+SERVICE_PID_FILE=/var/run/tor/tor.pid
 
 start() {
-       [ -f $DEFAULT ] && . $DEFAULT
-       [ -d $LOG_D ] || ( mkdir -m 0755 -p $LOG_D && chown $RUN_USER:$RUN_GROUP $LOG_D )
-       [ -d $LIB_D ] || ( mkdir -m 0700 -p $LIB_D && chown $RUN_USER:$RUN_GROUP $LIB_D )
-       [ -d $RUN_D ] || mkdir -p $RUN_D
-       [ -f $PID_F ] || ( touch $PID_F && chown $RUN_USER:$RUN_GROUP $PID_F )
-       $BIN $OPTIONS
+       user_exists tor 52 || user_add tor 52
+       group_exists tor 52 || group_add tor 52
+       [ -d /var/run/tor ] || {
+               mkdir -m 0755 -p /var/run/tor
+               chown tor:tor /var/run/tor
+       }
+       [ -d /var/lib/tor ] || {
+               mkdir -m 0755 -p /var/lib/tor
+               chmod 0700 /var/lib/tor
+               chown tor:tor /var/lib/tor
+       }
+       [ -d /var/log/tor ] || {
+               mkdir -m 0755 -p /var/log/tor
+               chown tor:tor /var/log/tor
+       }
+       service_start /usr/sbin/tor
 }
 
 stop() {
-       [ -f $PID_F ] && kill $(cat $PID_F)
+       service_stop /usr/sbin/tor
 }
-
index a390a6e2d816ba7e362ba4aa2d8dcc8dc15080cd..d5e52709d9a007cb2f1782e5428f4900c0133831 100644 (file)
@@ -19,4 +19,4 @@
  #ExitPolicy reject *:*
  
 +User tor
-+PidFile @LOCALSTATEDIR@/run/tor.pid
++PidFile @LOCALSTATEDIR@/run/tor/tor.pid