ipq40xx: add BDFs for Linksys WHW03 V1
authorRodrigo Balerdi <lanchon@gmail.com>
Sun, 30 Jun 2024 22:45:43 +0000 (19:45 -0300)
committerRobert Marko <robimarko@gmail.com>
Thu, 4 Jul 2024 17:14:20 +0000 (19:14 +0200)
BDFs come from latest firmware, version 1.1.19.209880 (2022-06-20):
- /lib/firmware/IPQ4019/v1/FCC/boardData_1_0_IPQ4019_DK04_2G.bin
- /lib/firmware/IPQ4019/v1/FCC/boardData_1_0_IPQ4019_DK04_5G.bin
- /lib/firmware/QCA9888/v1/FCC/boardData_2_0_QCA9888_5G_Y9690_SBS_HB.bin

Signed-off-by: Rodrigo Balerdi <lanchon@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/15844
Signed-off-by: Robert Marko <robimarko@gmail.com>
package/firmware/ipq-wifi/Makefile
target/linux/ipq40xx/image/generic.mk

index 09edfdd708a2509bbdfb06a22763743e84a82da6..917818db4a6880c437dd8048e2fd1a71041b8bfa 100644 (file)
@@ -38,6 +38,7 @@ ALLWIFIBOARDS:= \
        linksys_mx4200 \
        linksys_mx5300 \
        linksys_mx8500 \
+       linksys_whw03 \
        netgear_lbr20 \
        netgear_rax120v2 \
        netgear_sxk80 \
@@ -160,6 +161,7 @@ $(eval $(call generate-ipq-wifi-package,edimax_cax1800,Edimax CAX1800))
 $(eval $(call generate-ipq-wifi-package,linksys_mx4200,Linksys MX4200))
 $(eval $(call generate-ipq-wifi-package,linksys_mx5300,Linksys MX5300))
 $(eval $(call generate-ipq-wifi-package,linksys_mx8500,Linksys MX8500))
+$(eval $(call generate-ipq-wifi-package,linksys_whw03,Linksys WHW03))
 $(eval $(call generate-ipq-wifi-package,netgear_lbr20,Netgear LBR20))
 $(eval $(call generate-ipq-wifi-package,netgear_rax120v2,Netgear RAX120v2))
 $(eval $(call generate-ipq-wifi-package,netgear_sxk80,Netgear SXK80))
index 5f8082c99f69f5b7cd13fd668e5ed98b1d4b802d..929cff72ea3002c7d484ded5295fd5417ed74ab2 100644 (file)
@@ -739,7 +739,7 @@ define Device/linksys_whw03
        IMAGES += factory.bin
        IMAGE/factory.bin  := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | linksys-image type=WHW03
        DEVICE_PACKAGES := ath10k-firmware-qca9888-ct kmod-leds-pca963x kmod-spi-dev kmod-bluetooth \
-               kmod-fs-ext4 e2fsprogs kmod-fs-f2fs mkf2fs losetup
+               kmod-fs-ext4 e2fsprogs kmod-fs-f2fs mkf2fs losetup ipq-wifi-linksys_whw03
 endef
 TARGET_DEVICES += linksys_whw03