projects
/
openwrt
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
fff878c
)
libselinux: fix compilation with musl 1.2.4
author
Robert Marko
<robimarko@gmail.com>
Mon, 8 May 2023 10:47:29 +0000
(12:47 +0200)
committer
Christian Marangi
<ansuelsmth@gmail.com>
Mon, 15 May 2023 18:39:21 +0000
(20:39 +0200)
musl 1.2.4 deprecated legacy "LFS64" ("large file support") interfaces so
just having _GNU_SOURCE defined is not enough anymore.
_LARGEFILE64_SOURCE has to be defined in the source, or CFLAGS can be used
to pass -D_LARGEFILE64_SOURCE to allow to keep using LFS64 definitions.
Signed-off-by: Robert Marko <robimarko@gmail.com>
package/libs/libselinux/Makefile
patch
|
blob
|
history
diff --git
a/package/libs/libselinux/Makefile
b/package/libs/libselinux/Makefile
index 7246d855668dd82a951c5034210c7aa5b483d20e..a794270450413ad7ba54c741316582e2610ea42a 100644
(file)
--- a/
package/libs/libselinux/Makefile
+++ b/
package/libs/libselinux/Makefile
@@
-115,6
+115,7
@@
HOST_MAKE_FLAGS += \
ifeq ($(CONFIG_USE_MUSL),y)
MAKE_FLAGS += FTS_LDLIBS=-lfts
+TARGET_CFLAGS += -D_LARGEFILE64_SOURCE
endif
MAKE_FLAGS += \