x86/resctrl: Rename the config option INTEL_RDT to RESCTRL
authorBabu Moger <Babu.Moger@amd.com>
Wed, 21 Nov 2018 20:28:39 +0000 (20:28 +0000)
committerBorislav Petkov <bp@suse.de>
Thu, 22 Nov 2018 19:16:19 +0000 (20:16 +0100)
The resource control feature is supported by both Intel and AMD. So,
rename CONFIG_INTEL_RDT to the vendor-neutral CONFIG_RESCTRL.

Now CONFIG_RESCTRL will be used for both Intel and AMD to enable
Resource Control support. Update the texts in config and condition
accordingly.

 [ bp: Simplify Kconfig text. ]

Signed-off-by: Babu Moger <babu.moger@amd.com>
Signed-off-by: Borislav Petkov <bp@suse.de>
Cc: Andrew Morton <akpm@linux-foundation.org>
Cc: Andy Lutomirski <luto@kernel.org>
Cc: Arnd Bergmann <arnd@arndb.de>
Cc: Brijesh Singh <brijesh.singh@amd.com>
Cc: "Chang S. Bae" <chang.seok.bae@intel.com>
Cc: David Miller <davem@davemloft.net>
Cc: David Woodhouse <dwmw2@infradead.org>
Cc: Dmitry Safonov <dima@arista.com>
Cc: Fenghua Yu <fenghua.yu@intel.com>
Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: "H. Peter Anvin" <hpa@zytor.com>
Cc: Ingo Molnar <mingo@redhat.com>
Cc: Jann Horn <jannh@google.com>
Cc: Joerg Roedel <jroedel@suse.de>
Cc: Jonathan Corbet <corbet@lwn.net>
Cc: Josh Poimboeuf <jpoimboe@redhat.com>
Cc: Kate Stewart <kstewart@linuxfoundation.org>
Cc: "Kirill A. Shutemov" <kirill.shutemov@linux.intel.com>
Cc: <linux-doc@vger.kernel.org>
Cc: Mauro Carvalho Chehab <mchehab+samsung@kernel.org>
Cc: Paolo Bonzini <pbonzini@redhat.com>
Cc: Peter Zijlstra <peterz@infradead.org>
Cc: Philippe Ombredanne <pombredanne@nexb.com>
Cc: Pu Wen <puwen@hygon.cn>
Cc: <qianyue.zj@alibaba-inc.com>
Cc: "Rafael J. Wysocki" <rafael@kernel.org>
Cc: Reinette Chatre <reinette.chatre@intel.com>
Cc: Rian Hunter <rian@alum.mit.edu>
Cc: Sherry Hurwitz <sherry.hurwitz@amd.com>
Cc: Suravee Suthikulpanit <suravee.suthikulpanit@amd.com>
Cc: Thomas Gleixner <tglx@linutronix.de>
Cc: Thomas Lendacky <Thomas.Lendacky@amd.com>
Cc: Tony Luck <tony.luck@intel.com>
Cc: Vitaly Kuznetsov <vkuznets@redhat.com>
Cc: <xiaochen.shen@intel.com>
Link: https://lkml.kernel.org/r/20181121202811.4492-9-babu.moger@amd.com
arch/x86/Kconfig
arch/x86/include/asm/resctrl_sched.h
arch/x86/kernel/cpu/Makefile
arch/x86/kernel/cpu/resctrl/Makefile
include/linux/sched.h

index 9d734f3c8234d4bbdd44bb06518a768a6b9b7d02..2d0577e805d24c6ae9b7239c09181508dc5b6688 100644 (file)
@@ -448,15 +448,23 @@ config RETPOLINE
          code are eliminated. Since this includes the syscall entry path,
          it is not entirely pointless.
 
-config INTEL_RDT
-       bool "Intel Resource Director Technology support"
-       depends on X86 && CPU_SUP_INTEL
+config RESCTRL
+       bool "Resource Control support"
+       depends on X86 && (CPU_SUP_INTEL || CPU_SUP_AMD)
        select KERNFS
        help
-         Select to enable resource allocation and monitoring which are
-         sub-features of Intel Resource Director Technology(RDT). More
-         information about RDT can be found in the Intel x86
-         Architecture Software Developer Manual.
+         Enable Resource Control support.
+
+         Provide support for the allocation and monitoring of system resources
+         usage by the CPU.
+
+         Intel calls this Intel Resource Director Technology
+         (Intel(R) RDT). More information about RDT can be found in the
+         Intel x86 Architecture Software Developer Manual.
+
+         AMD calls this AMD Platform Quality of Service (AMD QoS).
+         More information about AMD QoS can be found in the AMD64 Technology
+         Platform Quality of Service Extensions manual.
 
          Say N if unsure.
 
index 6e082697a613877aec85c9c69d854fa48a5ae654..54990fe2a3ae80e949128475a7d59bda819178e3 100644 (file)
@@ -2,7 +2,7 @@
 #ifndef _ASM_X86_RESCTRL_SCHED_H
 #define _ASM_X86_RESCTRL_SCHED_H
 
-#ifdef CONFIG_INTEL_RDT
+#ifdef CONFIG_RESCTRL
 
 #include <linux/sched.h>
 #include <linux/jump_label.h>
@@ -88,6 +88,6 @@ static inline void resctrl_sched_in(void)
 
 static inline void resctrl_sched_in(void) {}
 
-#endif /* CONFIG_INTEL_RDT */
+#endif /* CONFIG_RESCTRL */
 
 #endif /* _ASM_X86_RESCTRL_SCHED_H */
index 8501d16dd642db0d834797f317bc7b2325cec584..dc4acaa1549def4f31a17d035bb22b58b45619f4 100644 (file)
@@ -39,7 +39,7 @@ obj-$(CONFIG_CPU_SUP_UMC_32)          += umc.o
 obj-$(CONFIG_X86_MCE)                  += mcheck/
 obj-$(CONFIG_MTRR)                     += mtrr/
 obj-$(CONFIG_MICROCODE)                        += microcode/
-obj-$(CONFIG_INTEL_RDT)                        += resctrl/
+obj-$(CONFIG_RESCTRL)                  += resctrl/
 
 obj-$(CONFIG_X86_LOCAL_APIC)           += perfctr-watchdog.o
 
index fa3cb91d7849dc06758ad52cb4b659f767a8562f..6895049ceef730ddfb084254b470bec7f0b6aebd 100644 (file)
@@ -1,4 +1,4 @@
 # SPDX-License-Identifier: GPL-2.0
-obj-$(CONFIG_INTEL_RDT)        += core.o rdtgroup.o monitor.o
-obj-$(CONFIG_INTEL_RDT)        += ctrlmondata.o pseudo_lock.o
+obj-$(CONFIG_RESCTRL)  += core.o rdtgroup.o monitor.o
+obj-$(CONFIG_RESCTRL)  += ctrlmondata.o pseudo_lock.o
 CFLAGS_pseudo_lock.o = -I$(src)
index a51c13c2b1a0316b00f928bc9e5afaa2ec949d83..7952dfba2c76a1d2429cb4f46325a8ddbaf2d4a8 100644 (file)
@@ -993,7 +993,7 @@ struct task_struct {
        /* cg_list protected by css_set_lock and tsk->alloc_lock: */
        struct list_head                cg_list;
 #endif
-#ifdef CONFIG_INTEL_RDT
+#ifdef CONFIG_RESCTRL
        u32                             closid;
        u32                             rmid;
 #endif