mxs: adapt default package list for Duckbill devices
authorMichael Heimpold <mhei@heimpold.de>
Thu, 28 Nov 2024 07:00:36 +0000 (08:00 +0100)
committerZoltan HERPAI <wigyori@uid0.hu>
Wed, 5 Feb 2025 21:00:09 +0000 (22:00 +0100)
Replace outdated package names, order the remaining.

firewall4 is added again, since it is enabled by default.
The device is not a router by default, so this package
makes no sense in the default config. User can enable it
by theirself, or it will be automatically pulled via
dependency, e.g. luci-app-firewall.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
target/linux/mxs/image/Makefile

index 0281600da0e20aad6ccba8c7187a285417b0bd54..12e71361444e8764386b2278d4446f50991a9ffb 100644 (file)
@@ -68,8 +68,8 @@ endef
 define Device/i2se_duckbill
   DEVICE_VENDOR := I2SE
   DEVICE_MODEL := Duckbill
-  DEVICE_PACKAGES := -dnsmasq -ppp -ip6tables -iptables -mtd \
-       uboot-envtools kmod-leds-gpio -kmod-nf-nathelper
+  DEVICE_PACKAGES := -dnsmasq -firewall4 -mtd -nftables -odhcpd-ipv6only -ppp -kmod-nft-offload \
+       uboot-envtools kmod-leds-gpio
   SUPPORTED_DEVICES := i2se,duckbill
   SOC := imx28
   KERNEL := kernel-bin