ramips: mt7621: use lzma-loader for Sercomm NA502s
authorAndreas Böhler <dev@aboehler.at>
Sun, 15 Sep 2024 21:35:08 +0000 (23:35 +0200)
committerChuanhong Guo <gch981213@gmail.com>
Tue, 17 Sep 2024 13:45:53 +0000 (21:45 +0800)
This fixes a well-known "LZMA ERROR 1" error on Sercomm NA502s, reported
on the OpneWrt forum [0].

[0] https://forum.openwrt.org/t/206640

Signed-off-by: Andreas Böhler <dev@aboehler.at>
target/linux/ramips/image/mt7621.mk

index bf700674ef53b00c04b92730c3d334fcff6494af..495ba4f7da8a48200a520cb54c6fcee8d3cb4bd3 100644 (file)
@@ -2384,6 +2384,7 @@ TARGET_DEVICES += sercomm_na502
 
 define Device/sercomm_na502s
   $(Device/nand)
+  $(Device/uimage-lzma-loader)
   IMAGE_SIZE := 20971520
   DEVICE_VENDOR := SERCOMM
   DEVICE_MODEL := NA502S