projects
/
openwrt
/
staging
/
rmilecki.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
882e301
)
scripts: fix checkpatch.pl for changed license dir
author
Paul Spooren
<mail@aparcar.org>
Tue, 22 Sep 2020 19:08:58 +0000
(09:08 -1000)
committer
Adrian Schmutzler
<freifunk@adrianschmutzler.de>
Sun, 14 Feb 2021 18:21:38 +0000
(19:21 +0100)
As multiple LICENSES are shipped and no longer just LICENSE, modify the
OpenWrt tree detection in checkpatch.pl.
Signed-off-by: Paul Spooren <mail@aparcar.org>
scripts/checkpatch.pl
patch
|
blob
|
history
diff --git
a/scripts/checkpatch.pl
b/scripts/checkpatch.pl
index 8ffc093548885de2baede81a0471e9e74652e306..81b1ffcb56007f9c5df5448da583e809daf95b38 100755
(executable)
--- a/
scripts/checkpatch.pl
+++ b/
scripts/checkpatch.pl
@@
-1113,7
+1113,7
@@
sub top_of_openwrt_tree {
my ($root) = @_;
my @tree_check = (
- "BSDmakefile", "Config.in", "LICENSE", "Makefile", "README.md",
+ "BSDmakefile", "Config.in", "LICENSE
S
", "Makefile", "README.md",
"feeds.conf.default", "include", "package", "rules.mk",
"scripts", "target", "toolchain", "tools"
);