projects
/
openwrt
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
a3446cb
)
rules.mk: add ESED command
author
Konstantin Demin
<rockdrilla@gmail.com>
Mon, 5 Mar 2018 09:46:44 +0000
(12:46 +0300)
committer
Jo-Philipp Wich
<jo@mein.io>
Tue, 18 Dec 2018 10:28:13 +0000
(11:28 +0100)
ESED is SED with extended regular expressions turned on.
Command line and usage are the same as for SED.
Signed-off-by: Konstantin Demin <rockdrilla@gmail.com>
(backported from
d3b43f49acb38cbe364da8735c9617427edd3d81
)
rules.mk
patch
|
blob
|
history
diff --git
a/rules.mk
b/rules.mk
index 6b881a0c619c11e63d7504b31e4c16f4271f81bc..15b330c792615156d9bdb65fa847ce9fb2c80164 100644
(file)
--- a/
rules.mk
+++ b/
rules.mk
@@
-265,6
+265,7
@@
TARGET_CC:=$(TARGET_CROSS)gcc
TARGET_CXX:=$(TARGET_CROSS)g++
KPATCH:=$(SCRIPT_DIR)/patch-kernel.sh
SED:=$(STAGING_DIR_HOST)/bin/sed -i -e
+ESED:=$(STAGING_DIR_HOST)/bin/sed -E -i -e
CP:=cp -fpR
LN:=ln -sf
XARGS:=xargs -r