projects
/
openwrt
/
staging
/
hauke.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
062456e
)
fix potential rootfs owner/group mismatch (tgz root only, patch from #4562)
author
Felix Fietkau
<nbd@openwrt.org>
Thu, 19 Feb 2009 17:19:29 +0000
(17:19 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Thu, 19 Feb 2009 17:19:29 +0000
(17:19 +0000)
SVN-Revision: 14569
include/image.mk
patch
|
blob
|
history
diff --git
a/include/image.mk
b/include/image.mk
index 2b239ca3a37211c88946a17a50d2f1e45131acf7..7de2d6346e7fbd078dbdf8b0dab9430b475155bd 100644
(file)
--- a/
include/image.mk
+++ b/
include/image.mk
@@
-62,7
+62,7
@@
ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
ifeq ($(CONFIG_TARGET_ROOTFS_TGZ),y)
define Image/mkfs/tgz
- $(TAR) -zcf $(BIN_DIR)/openwrt-$(BOARD)-rootfs.tgz --
owner=root --group=root
-C $(TARGET_DIR)/ .
+ $(TAR) -zcf $(BIN_DIR)/openwrt-$(BOARD)-rootfs.tgz --
numeric-owner --owner=0 --group=0
-C $(TARGET_DIR)/ .
endef
endif