+++ b/Makefile
@@ -416,7 +416,8 @@ HOSTCXX = g++
endif
-
+
export KBUILD_USERCFLAGS := -Wall -Wmissing-prototypes -Wstrict-prototypes \
- -O2 -fomit-frame-pointer -std=gnu89
+ -O2 -fomit-frame-pointer -std=gnu89 \
+ -Wdeclaration-after-statement
export KBUILD_USERLDFLAGS :=
-
+
KBUILD_HOSTCFLAGS := $(KBUILD_USERCFLAGS) $(HOST_LFS_CFLAGS) $(HOSTCFLAGS)
--- a/arch/arm64/kernel/vdso32/Makefile
+++ b/arch/arm64/kernel/vdso32/Makefile
+++ b/scripts/mod/modpost.c
@@ -844,8 +844,10 @@ static int match(const char *sym, const
{
- const char *p;
- while (*pat) {
+ const char *p;
+ while (*pat) {
+ const char *endp;
+
- p = *pat++;
+ p = *pat++;
- const char *endp = p + strlen(p) - 1;
+ endp = p + strlen(p) - 1;
-
- /* "*foo*" */
- if (*p == '*' && *endp == '*') {
+
+ /* "*foo*" */
+ if (*p == '*' && *endp == '*') {
--- a/Makefile
+++ b/Makefile
@@ -498,7 +498,7 @@ KBUILD_CFLAGS := -Wall -Wundef -Werror
- -fno-strict-aliasing -fno-common -fshort-wchar -fno-PIE \
- -Werror=implicit-function-declaration -Werror=implicit-int \
- -Werror=return-type -Wno-format-security \
+ -fno-strict-aliasing -fno-common -fshort-wchar -fno-PIE \
+ -Werror=implicit-function-declaration -Werror=implicit-int \
+ -Werror=return-type -Wno-format-security \
- -std=gnu89
+ -std=gnu11
KBUILD_CPPFLAGS := -D__KERNEL__
+++ b/Makefile
@@ -416,7 +416,7 @@ HOSTCXX = g++
endif
-
+
export KBUILD_USERCFLAGS := -Wall -Wmissing-prototypes -Wstrict-prototypes \
- -O2 -fomit-frame-pointer -std=gnu89 \
+ -O2 -fomit-frame-pointer -std=gnu11 \
- -Wdeclaration-after-statement
+ -Wdeclaration-after-statement
export KBUILD_USERLDFLAGS :=
+