mediatek: filogic: add support for NRadio C8-668GL
authorYaoguang Bai <0xdeadc0de@badguys.club>
Tue, 26 Nov 2024 09:18:28 +0000 (17:18 +0800)
committerJohn Crispin <john@phrozen.org>
Fri, 13 Dec 2024 14:29:04 +0000 (15:29 +0100)
NRadio C8-668GL is a Wi-Fi 6 5G cellular router based on MediaTek MT7981B SoC.

- **SoC**: MediaTek MT7981B (2x Cortex-A53, 1.3GHz)
- **RAM**: Nanya NT5AD512M16C4-JR 1GB DDR4
- **Flash**: ESMT FC51L08SFY3A 8GB eMMC
- **Ethernet**:
  - 1x 2.5GbE (via GMAC0 and GPY211 PHY, shared with MT7531AE)
  - 3x 10/100/1000 Mbps (via MT7531AE, connected to GMAC0)
  - 5G Modem: GMAC1 (via GPY211 PHY - RTL8125BG - RM520N-GL)
- **Wi-Fi**: MediaTek MT7976CN (2.4GHz/5GHz, 802.11ax, 2x2 MIMO, AX3000)
- **Buttons**: Reset, WPS
- **LEDs**: Power, 5G, 4G, WiFi
- **SIM Slot**: 1x Nano SIM
- **5G Modem**: Quectel RM520N-GL (Snapdragon™ X62)
- **Power**: 12V/2A DC, 5.5×2.1 connector

The MAC addresses are derived from the `fac_mac` field in the `bdinfo` partition, formatted as `fac_mac = HWMAC`. The allocation is as follows:

| Vendor  | OpenWrt Interface | Address       | Notes                                          |
|---------|-------------------|---------------|------------------------------------------------|
| LAN     | br-lan            | Label MAC     | Default                                        |
| WAN     | lan4              | Label MAC+1   | Only when lan4 is switched to WAN             |
| 2.4GHz  | phy0-ap0          | Label MAC     |                                                |
| 5GHz    | phy1-ap0          | Label MAC     | (Local Admin bit set)                         |
| Modem   | eth1              | Label MAC+2   |                                                |

1. Log in to the router via `http://192.168.66.1`/.
2. Upgrade the official firmware to dual-system mode.
3. Select **Burn second system** and upload the `sysupgrade.bin` image.
   - Download the image from the OpenWrt build system or build it yourself using the OpenWrt buildroot.
4. Wait for 30 seconds and click **Switch system**.
5. The device will reboot and switch to OpenWrt.

Set the U-Boot environment variable `boot_system=0` and reboot:
```bash
fw_setenv boot_system 0
```

Power off the router, hold the **WPS button**, and power it back on.

1. Rename the stock firmware file to **`recovery.bin`**.
2. Set your PC's Ethernet IP to **192.168.1.88** and connect it to the lan1 port on the router.
3. Run a TFTP server and place the `recovery.bin` file in its root directory.
4. Power off the router, press and hold the **Reset button**, and power it back on.
5. Release the Reset button when the TFTP server shows activity.
6. Wait for the router to flash the firmware and reboot automatically.

- By default, `lan4` is part of `br-lan` and uses the label MAC address.
- To query the RM520N-GL module, use the following command:
  ```bash
  cat /dev/ttyUSB2 & printf 'ATI\r\n' > /dev/ttyUSB2
  ```

Signed-off-by: Yaoguang Bai <0xdeadc0de@badguys.club>
Link: https://github.com/openwrt/openwrt/pull/17093
Signed-off-by: John Crispin <john@phrozen.org>
package/boot/uboot-envtools/files/mediatek_filogic
target/linux/mediatek/dts/mt7981b-nradio-c8-668gl.dts [new file with mode: 0644]
target/linux/mediatek/filogic/base-files/etc/board.d/01_leds
target/linux/mediatek/filogic/base-files/etc/board.d/02_network
target/linux/mediatek/filogic/base-files/etc/hotplug.d/ieee80211/11_fix_wifi_mac
target/linux/mediatek/filogic/base-files/lib/upgrade/platform.sh
target/linux/mediatek/image/filogic.mk

index 5bde699a47a47d2f160ba0a02103ef00e88761ec..d0a15e34736c5d34c49fefd135b6641f07905d25 100644 (file)
@@ -57,7 +57,8 @@ acer,vero-w6m|\
 glinet,gl-mt2500|\
 glinet,gl-mt6000|\
 glinet,gl-x3000|\
-glinet,gl-xe3000)
+glinet,gl-xe3000|\
+nradio,c8-668gl)
        local envdev=$(find_mmc_part "u-boot-env")
        ubootenv_add_uci_config "$envdev" "0x0" "0x80000"
        ;;
diff --git a/target/linux/mediatek/dts/mt7981b-nradio-c8-668gl.dts b/target/linux/mediatek/dts/mt7981b-nradio-c8-668gl.dts
new file mode 100644 (file)
index 0000000..d1b74f2
--- /dev/null
@@ -0,0 +1,264 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+/dts-v1/;
+
+#include "mt7981.dtsi"
+
+/ {
+       model = "NRadio C8-668GL";
+       compatible = "nradio,c8-668gl", "mediatek,mt7981";
+
+       aliases {
+               ethernet0 = &gmac0;
+               led-boot = &led_power;
+               led-failsafe = &led_power;
+               led-running = &led_power;
+               led-upgrade = &led_power;
+               serial0 = &uart0;
+       };
+
+       chosen {
+               stdout-path = "serial0:115200n1";
+               /* If official system version < 1.9.2.n6.c3, use root=PARTLABEL=rootfs */
+               bootargs = "console=ttyS0,115200n1 root=PARTLABEL=rootfs_2nd rootwait";
+       };
+
+       gpio-keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&pio 1 GPIO_ACTIVE_LOW>;
+               };
+
+               wps {
+                       label = "wps";
+                       linux,code = <KEY_WPS_BUTTON>;
+                       gpios = <&pio 9 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       gpio-export {
+               compatible = "gpio-export";
+               #size-cells = <0>;
+
+               cpepower {
+                       gpio-export,name = "cpe-pwr";
+                       gpio-export,output = <0>;
+                       gpios = <&pio 31 GPIO_ACTIVE_LOW>;
+               };
+
+               cpesel0 {
+                       gpio-export,name = "cpe-sel0";
+                       gpio-export,output = <1>;
+                       gpios = <&pio 30 GPIO_ACTIVE_HIGH>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_power: power {
+                       color = <LED_COLOR_ID_BLUE>;
+                       function = LED_FUNCTION_POWER;
+                       gpios = <&pio 10 GPIO_ACTIVE_LOW>;
+               };
+
+               led-cellular-5g {
+                       color = <LED_COLOR_ID_BLUE>;
+                       function = LED_FUNCTION_INDICATOR;
+                       function-enumerator = <0>;
+                       gpios = <&pio 11 GPIO_ACTIVE_LOW>;
+               };
+
+               led-cellular-4g {
+                       color = <LED_COLOR_ID_BLUE>;
+                       function = LED_FUNCTION_INDICATOR;
+                       function-enumerator = <1>;
+                       gpios = <&pio 12 GPIO_ACTIVE_LOW>;
+               };
+
+               led-wifi {
+                       color = <LED_COLOR_ID_BLUE>;
+                       function = LED_FUNCTION_WLAN;
+                       gpios = <&pio 13 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&uart0 {
+       status = "okay";
+};
+
+&watchdog {
+       status = "okay";
+};
+
+&mmc0 {
+       pinctrl-names = "default", "state_uhs";
+       pinctrl-0 = <&mmc0_pins_default>;
+       pinctrl-1 = <&mmc0_pins_uhs>;
+       bus-width = <8>;
+       max-frequency = <52000000>;
+       cap-mmc-highspeed;
+       vmmc-supply = <&reg_3p3v>;
+       non-removable;
+       status = "okay";
+
+       card@0 {
+               compatible = "mmc-card";
+               reg = <0>;
+
+               block {
+                       compatible = "block-device";
+                       partitions {
+                               block-partition-env {
+                                       partname = "u-boot-env";
+
+                                       nvmem-layout {
+                                               compatible = "u-boot,env";
+                                       };
+                               };
+
+                               block-partition-factory {
+                                       partname = "factory";
+
+                                       nvmem-layout {
+                                               compatible = "fixed-layout";
+                                               #address-cells = <1>;
+                                               #size-cells = <1>;
+
+                                               eeprom_factory_0: eeprom@0 {
+                                                       reg = <0x0 0x1000>;
+                                               };
+                                       };
+                               };
+                       };
+               };
+       };
+};
+
+&pio {
+       mmc0_pins_default: mmc0-pins-default {
+               mux {
+                       function = "flash";
+                       groups = "emmc_45";
+               };
+       };
+
+       mmc0_pins_uhs: mmc0-pins-uhs {
+               mux {
+                       function = "flash";
+                       groups = "emmc_45";
+               };
+       };
+};
+
+&eth {
+       status = "okay";
+
+       gmac0: mac@0 {
+               compatible = "mediatek,eth-mac";
+               reg = <0>;
+               phy-mode = "2500base-x";
+
+               fixed-link {
+                       speed = <2500>;
+                       full-duplex;
+                       pause;
+               };
+       };
+
+       gmac1: mac@1 {
+               compatible = "mediatek,eth-mac";
+               reg = <1>;
+               phy-mode = "2500base-x";
+               phy-handle = <&phy21>;
+       };
+
+       mdio: mdio-bus {
+               #address-cells = <1>;
+               #size-cells = <0>;
+
+               phy5: ethernet-phy@5 {
+                       compatible = "ethernet-phy-ieee802.3-c45";
+                       reg = <5>;
+                       reset-gpios = <&pio 7 GPIO_ACTIVE_LOW>;
+                       reset-assert-us = <600>;
+                       reset-deassert-us = <20000>;
+               };
+
+               phy21: ethernet-phy@21 {
+                       compatible = "ethernet-phy-ieee802.3-c45";
+                       reg = <21>;
+                       reset-gpios = <&pio 8 GPIO_ACTIVE_LOW>;
+                       reset-assert-us = <600>;
+                       reset-deassert-us = <20000>;
+               };
+
+               switch@1f {
+                       compatible = "mediatek,mt7531";
+                       reg = <31>;
+                       reset-gpios = <&pio 39 GPIO_ACTIVE_HIGH>;
+                       interrupt-controller;
+                       #interrupt-cells = <1>;
+                       interrupt-parent = <&pio>;
+                       interrupts = <38 IRQ_TYPE_LEVEL_HIGH>;
+
+                       ports {
+                               #address-cells = <1>;
+                               #size-cells = <0>;
+
+                               port@1 {
+                                       reg = <1>;
+                                       label = "lan1";
+                               };
+
+                               port@2 {
+                                       reg = <2>;
+                                       label = "lan2";
+                               };
+
+                               port@3 {
+                                       reg = <3>;
+                                       label = "lan3";
+                               };
+
+                               port@5 {
+                                       reg = <5>;
+                                       label = "lan4";
+                                       phy-mode = "2500base-x";
+                                       phy-handle = <&phy5>;
+                               };
+
+                               port@6 {
+                                       reg = <6>;
+                                       label = "cpu";
+                                       ethernet = <&gmac0>;
+                                       phy-mode = "2500base-x";
+
+                                       fixed-link {
+                                               speed = <2500>;
+                                               full-duplex;
+                                               pause;
+                                       };
+                               };
+                       };
+               };
+       };
+};
+
+&usb_phy {
+       status = "okay";
+};
+
+&xhci {
+       status = "okay";
+};
+
+&wifi {
+       nvmem-cells = <&eeprom_factory_0>;
+       nvmem-cell-names = "eeprom";
+       status = "okay";
+};
index 64df50eb0a18e894276a1c421e4e1291b91f1153..2496323d873a302cac262bdda42d41f1ff69c9e2 100644 (file)
@@ -66,6 +66,10 @@ nokia,ea0326gmp)
        ucidef_set_led_netdev "lan" "LAN" "green:lan" "br-lan" "link"
        ucidef_set_led_netdev "wlan" "WLAN" "green:wlan" "phy1-ap0" "link"
        ;;
+nradio,c8-668gl)
+       ucidef_set_led_netdev "wifi" "WIFI" "blue:wlan" "phy1-ap0" "link"
+       ucidef_set_led_netdev "5g" "5G" "blue:indicator-0" "eth1" "link"
+       ;;
 openembed,som7981)
        ucidef_set_led_netdev "lanact" "LANACT" "green:lan" "eth1" "rx tx"
        ucidef_set_led_netdev "lanlink" "LANLINK" "amber:lan" "eth1" "link"
index 78483442d764f71c253aadbc8423d581e38fa91b..2a133813263c16b06a7157e53859920d10737959 100644 (file)
@@ -43,6 +43,7 @@ mediatek_setup_interfaces()
        jdcloud,re-cp-03|\
        mediatek,mt7981-rfb|\
        netcore,n60|\
+       nradio,c8-668gl|\
        ruijie,rg-x60-pro|\
        unielec,u7981-01*|\
        zbtlink,zbt-z8102ax|\
@@ -165,6 +166,11 @@ mediatek_setup_macs()
                lan_mac=$(mtd_get_mac_ascii u-boot-env mac)
                label_mac=$lan_mac
                ;;
+       nradio,c8-668gl)
+               lan_mac=$(mmc_get_mac_ascii bdinfo "fac_mac ")
+               wan_mac=$(macaddr_add "$lan_mac" 2)
+               label_mac=$lan_mac
+               ;;
        qihoo,360t7)
                lan_mac=$(mtd_get_mac_ascii factory lanMac)
                wan_mac=$(macaddr_add "$lan_mac" 1)
index fb67323e7b089cc56daf514b9e6ef71cff5760b8..41c425e5579e79e14401fbe3b2e295945f8624ba 100644 (file)
@@ -136,6 +136,11 @@ case "$board" in
                [ "$PHYNBR" = "0" ] && macaddr_add $addr 1 > /sys${DEVPATH}/macaddress
                [ "$PHYNBR" = "1" ] && macaddr_add $addr 2 > /sys${DEVPATH}/macaddress
                ;;
+       nradio,c8-668gl)
+               hw_mac_addr=$(mmc_get_mac_ascii bdinfo "fac_mac ")
+               [ "$PHYNBR" = "0" ] && echo "$hw_mac_addr" > /sys${DEVPATH}/macaddress
+               [ "$PHYNBR" = "1" ] && macaddr_setbit_la $hw_mac_addr > /sys${DEVPATH}/macaddress
+               ;;
        openembed,som7981)
                [ "$PHYNBR" = "1" ] && cat /sys/class/net/eth0/address > /sys${DEVPATH}/macaddress
                ;;
index fb48ffc49f090dd8a168fea0959d1f8c914754c9..f3d5cb472e39a48bd6ff6904c0b8e03c67ed47f0 100755 (executable)
@@ -128,6 +128,12 @@ platform_do_upgrade() {
                CI_UBIPART="ubi0"
                nand_do_upgrade "$1"
                ;;
+       nradio,c8-668gl)
+               CI_DATAPART="rootfs_data"
+               CI_KERNPART="kernel_2nd"
+               CI_ROOTPART="rootfs_2nd"
+               emmc_do_upgrade "$1"
+               ;;
        ubnt,unifi-6-plus)
                CI_KERNPART="kernel0"
                EMMC_ROOT_DEV="$(cmdline_get_var root)"
@@ -181,6 +187,17 @@ platform_check_image() {
                        echo "Invalid image type."
                        return 1
                }
+               return 0
+               ;;
+       nradio,c8-668gl)
+               # tar magic `ustar`
+               magic="$(dd if="$1" bs=1 skip=257 count=5 2>/dev/null)"
+
+               [ "$magic" != "ustar" ] && {
+                       echo "Invalid image type."
+                       return 1
+               }
+
                return 0
                ;;
        *)
@@ -212,6 +229,7 @@ platform_copy_config() {
        glinet,gl-x3000|\
        glinet,gl-xe3000|\
        jdcloud,re-cp-03|\
+       nradio,c8-668gl|\
        smartrg,sdg-8612|\
        smartrg,sdg-8614|\
        smartrg,sdg-8622|\
index c18873e697d40d710e5fe1732da0fe827eced6e2..1fdb3036776852eb29897ff367821ab8fbec4626 100644 (file)
@@ -1195,6 +1195,19 @@ define Device/nokia_ea0326gmp
 endef
 TARGET_DEVICES += nokia_ea0326gmp
 
+define Device/nradio_c8-668gl
+  DEVICE_VENDOR := NRadio
+  DEVICE_MODEL := C8-668GL
+  DEVICE_DTS := mt7981b-nradio-c8-668gl
+  DEVICE_DTS_DIR := ../dts
+  DEVICE_PACKAGES := kmod-mt7915e kmod-mt7981-firmware mt7981-wo-firmware \
+       kmod-usb-serial-option kmod-usb-net-cdc-ether kmod-usb-net-qmi-wwan \
+       kmod-usb3
+  IMAGE_SIZE := 131072k
+  IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata | check-size
+endef
+TARGET_DEVICES += nradio_c8-668gl
+
 define Device/openembed_som7981
   DEVICE_VENDOR := OpenEmbed
   DEVICE_MODEL := SOM7981