bpftools: fix libbpf pkgconfig file
authorTony Ambardar <itugrok@yahoo.com>
Mon, 1 Mar 2021 09:07:45 +0000 (01:07 -0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 29 Mar 2021 20:26:27 +0000 (22:26 +0200)
The pkgconfig file hardcodes a host library directory which cannot be
overridden by OpenWrt during builds. Use SED to fix this and potential
include directory problems, as is done with several other packages.

This fixes a strange issue intermittently seen building iproute2 on the
oxnas target:

iptables modules directory: /usr/lib/iptables
libc has setns: yes
SELinux support: no
libbpf support: no
libbpf version 0.3.0 is too low, please update it to at least 0.1.0
LIBBPF_FORCE=on set, but couldn't find a usable libbpf

Fixes: 2f0d672088c3 ("bpftools: add utility and library packages
supporting eBPF usage")
Reported-by: Russell Senior <russell@personaltelco.net>
Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
(cherry picked from commit 9e64e4ce26719ea81637b0e3d9754bd5190f0c21)

package/network/utils/bpftools/Makefile

index 7a25b357551bb61cbce66416c7028915041c526d..ab1e4aa0c4484f22b7b35acb6b045b3dff45079f 100644 (file)
@@ -145,6 +145,10 @@ define Build/InstallDev/libbpf
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib$(LIB_SUFFIX)/pkgconfig/libbpf.pc \
                $(1)/usr/lib/pkgconfig/
+       $(SED) 's,/usr/include,$$$${prefix}/include,g' \
+               $(1)/usr/lib/pkgconfig/libbpf.pc
+       $(SED) 's,/usr/lib,$$$${exec_prefix}/lib,g' \
+               $(1)/usr/lib/pkgconfig/libbpf.pc
 endef
 
 ifeq ($(BUILD_VARIANT),lib)