x86: add packages files to image bootfs
authorTomasz Maciej Nowak <tomek_n@o2.pl>
Tue, 20 Nov 2018 16:20:41 +0000 (17:20 +0100)
committerJo-Philipp Wich <jo@mein.io>
Tue, 18 Dec 2018 16:22:08 +0000 (17:22 +0100)
Add files to bootfs image from selected as built-in packages, which want
to install files to targets boot file system.

Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
(backported from 51e199fbe80acb6e95dff942280b0396e094032b)

target/linux/x86/image/Makefile

index 8a3cb327e3ccaef77e96e0fceb38a029db2e159e..fcdfcb8afb9b17b9cd0f3a55f7243d6d13ba0363 100644 (file)
@@ -83,6 +83,7 @@ ifneq ($(CONFIG_GRUB_IMAGES),)
                -e 's#@TIMEOUT@#$(GRUB_TIMEOUT)#g' \
                -e 's#@ROOT@#$(GRUB_ROOT)#g' \
                ./grub.cfg > $(KDIR)/root.grub/boot/grub/grub.cfg
+       -$(CP) $(STAGING_DIR_ROOT)/boot/. $(KDIR)/root.grub/boot/
        PADDING="$(CONFIG_TARGET_IMAGES_PAD)" SIGNATURE="$(SIGNATURE)" PATH="$(TARGET_PATH)" $(SCRIPT_DIR)/gen_image_generic.sh \
                $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
                $(CONFIG_TARGET_KERNEL_PARTSIZE) $(KDIR)/root.grub \
@@ -120,6 +121,7 @@ define Image/Build/iso
                -e 's#@CMDLINE@#root=/dev/sr0 rootfstype=iso9660 rootwait $(strip $(call Image/cmdline/$(1)) $(BOOTOPTS) $(GRUB_CONSOLE_CMDLINE))#g' \
                -e 's#@TIMEOUT@#$(GRUB_TIMEOUT)#g' \
                ./grub-iso.cfg > $(KDIR)/root.grub/boot/grub/grub.cfg
+       -$(CP) $(STAGING_DIR_ROOT)/boot/. $(KDIR)/root.grub/boot/
        mkisofs -R -b boot/grub/eltorito.img -no-emul-boot -boot-info-table \
                -o $(KDIR)/root.iso $(KDIR)/root.grub $(TARGET_DIR)
 endef