made xmms use new install function as an example
authorJohn Crispin <john@openwrt.org>
Sun, 7 Oct 2007 01:56:10 +0000 (01:56 +0000)
committerJohn Crispin <john@openwrt.org>
Sun, 7 Oct 2007 01:56:10 +0000 (01:56 +0000)
SVN-Revision: 9172

XOrg/app/xmms/Makefile

index 61c545110d6283b1b2d1c7d3516606a693f369c3..7228a1abce16043476633058f65141dd0ae7b909 100644 (file)
@@ -53,9 +53,7 @@ define Build/Compile
 endef
 
 define Package/xmms/install
-       $(INSTALL_DIR) $(1)/usr/{bin,share/xmms}
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/xmms $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/share/xmms/* $(1)/usr/share/xmms/
+       $(call pkg_install_files,$(1),/usr/bin/xmms /usr/share/xmms/)
 endef
 
 $(eval $(call BuildPackage,xmms))