Rename coova to coova-chilli (#2826)
authorFlorian Fainelli <florian@openwrt.org>
Fri, 2 May 2008 07:06:27 +0000 (07:06 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 2 May 2008 07:06:27 +0000 (07:06 +0000)
SVN-Revision: 11003

net/coova-chilli/Makefile [new file with mode: 0644]
net/coova/Makefile [deleted file]

diff --git a/net/coova-chilli/Makefile b/net/coova-chilli/Makefile
new file mode 100644 (file)
index 0000000..9298aa3
--- /dev/null
@@ -0,0 +1,61 @@
+# 
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=coova-chilli
+PKG_VERSION:=1.0.11
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://ap.coova-chilli.org/chilli/
+PKG_MD5SUM:=d932dc9ca42b90d56ef27552f049c44a
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/coova-chilli
+  SUBMENU:=Captive Portals
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+kmod-tun
+  TITLE:=Wireless LAN HotSpot controller (Coova Chilli Version)
+  URL:=http://www.coova-chilli.org/
+endef
+
+define Package/coova-chilli/description
+       CoovaChilli is an open source access controller for wireless LAN
+       access points and is based on ChilliSpot. It is used for authenticating
+       users of a wireless (or wired) LAN. It supports web based login (UAM)
+       which is today's standard for public HotSpots and it supports Wireless Protected
+       Access (WPA) which is the standard of the future. Authentication,
+       authorization and accounting (AAA) is handled by your favorite
+       radius server.
+endef
+
+define Package/coova-chilli/conffiles
+/etc/chilli.conf
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+define Package/coova-chilli/install
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/chilli.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/chilli
+       $(CP) $(PKG_INSTALL_DIR)/etc/chilli/* $(1)/etc/chilli/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/chilli* $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib*.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,coova-chilli))
diff --git a/net/coova/Makefile b/net/coova/Makefile
deleted file mode 100644 (file)
index badaa7f..0000000
+++ /dev/null
@@ -1,61 +0,0 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id: $
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=coova-chilli
-PKG_VERSION:=1.0.11
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://ap.coova.org/chilli/
-PKG_MD5SUM:=d932dc9ca42b90d56ef27552f049c44a
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/coova
-  SUBMENU:=Captive Portals
-  SECTION:=net
-  CATEGORY:=Network
-  DEPENDS:=+kmod-tun
-  TITLE:=Wireless LAN HotSpot controller (Coova Chilli Version)
-  URL:=http://www.coova.org/
-endef
-
-define Package/coova/description
-       CoovaChilli is an open source access controller for wireless LAN
-       access points and is based on ChilliSpot. It is used for authenticating
-       users of a wireless (or wired) LAN. It supports web based login (UAM)
-       which is today's standard for public HotSpots and it supports Wireless Protected
-       Access (WPA) which is the standard of the future. Authentication,
-       authorization and accounting (AAA) is handled by your favorite
-       radius server.
-endef
-
-define Package/coova/conffiles
-/etc/chilli.conf
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
-define Package/coova/install
-       $(INSTALL_DIR) $(1)/etc
-       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/chilli.conf $(1)/etc/
-       $(INSTALL_DIR) $(1)/etc/chilli
-       $(CP) $(PKG_INSTALL_DIR)/etc/chilli/* $(1)/etc/chilli/
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/chilli* $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib*.so.* $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,coova))