realtek: Fix old compatible for HPE 1920-8G PoE
authorSander Vanheule <sander@svanheule.net>
Fri, 24 Jan 2025 16:07:21 +0000 (17:07 +0100)
committerSander Vanheule <sander@svanheule.net>
Fri, 24 Jan 2025 16:07:21 +0000 (17:07 +0100)
Supported devices are listed in the metadata as the first part of the
DTS compatible. This normally follows the format "vendor,device".

When updating the device name of the 180W 1920-8G PoE an underscore was
used, instead of a comma, to join the vendor and device name. This will
lead to warnings for users wanting to sysupgrade a device with an older
compatible, as the device's info does not match the one the metadata.

Fixes: 987c96e88927 ("realtek: rename hpe,1920-8g-poe to match hardware")
Signed-off-by: Sander Vanheule <sander@svanheule.net>
target/linux/realtek/image/rtl838x.mk

index 34464316c7f21a226b6f1c00f1a73b8626017554..0d6acd483afb38cfdef6920259621f0861af06f6 100644 (file)
@@ -125,7 +125,7 @@ define Device/hpe_1920-8g-poe-180w
   DEVICE_MODEL := 1920-8G-PoE+ 180W (JG922A)
   DEVICE_PACKAGES += realtek-poe kmod-hwmon-gpiofan
   H3C_DEVICE_ID := 0x00010025
-  SUPPORTED_DEVICES += hpe_1920-8g-poe
+  SUPPORTED_DEVICES += hpe,1920-8g-poe
 endef
 TARGET_DEVICES += hpe_1920-8g-poe-180w