projects
/
openwrt
/
staging
/
chunkeey.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
a5f93fa
)
include: modify kernel.mk to build empty kmod packages if the referenced symbols...
author
Jo-Philipp Wich
<jow@openwrt.org>
Thu, 18 Jul 2013 15:41:09 +0000
(15:41 +0000)
committer
Jo-Philipp Wich
<jow@openwrt.org>
Thu, 18 Jul 2013 15:41:09 +0000
(15:41 +0000)
SVN-Revision: 37400
include/kernel.mk
patch
|
blob
|
history
diff --git
a/include/kernel.mk
b/include/kernel.mk
index cbf342a0d2b7244bfa535913bba9fc25755f5009..5442c9153f2aeb415fd146bc33e48a95a576ac48 100644
(file)
--- a/
include/kernel.mk
+++ b/
include/kernel.mk
@@
-176,9
+176,13
@@
$(call KernelPackage/$(1)/config)
endif
$(if $(CONFIG_PACKAGE_kmod-$(1)),
else
- compile: kmod-$(1)-unavailable
- kmod-$(1)-unavailable:
- @echo "WARNING: kmod-$(1) is not available in the kernel config" >&2
+ compile: $(1)-disabled
+ $(1)-disabled:
+ @echo "WARNING: kmod-$(1) is not available in the kernel config - generating empty package" >&2
+
+ define Package/kmod-$(1)/install
+ true
+ endef
)
endif
$$(eval $$(call BuildPackage,kmod-$(1)))