Actually copy over the new headers from compat
authorLuis R. Rodriguez <lrodriguez@atheros.com>
Tue, 12 Jan 2010 02:26:15 +0000 (18:26 -0800)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Tue, 12 Jan 2010 02:26:15 +0000 (18:26 -0800)
The last 3 patches removed carrying around some upstream
headers but we forgot to ensure compat-wireless copies them
over to our local tree.

Signed-off-by: Luis R. Rodriguez <lrodriguez@atheros.com>
scripts/admin-update.sh

index 7fecccf2f4cdc05277305bac9ba32ffa7fb5174c..c52ff6825d05080c842a406806a9b769cfade6bb 100755 (executable)
@@ -229,7 +229,7 @@ mkdir -p $COMPAT
 echo "Copying $GIT_COMPAT_TREE/ files..."
 cp $GIT_COMPAT_TREE/compat/*.c $COMPAT/
 cp $GIT_COMPAT_TREE/compat/Makefile $COMPAT/
-cp $GIT_COMPAT_TREE/include/linux/*.h include/linux/
+cp -a $GIT_COMPAT_TREE/include/linux/* include/linux/
 rm -f $COMPAT/*.mod.c
 
 # Refresh patches using quilt