[packages/rtorrent] fix build, adjust to new xmlrpc-c structure
authorMirko Vogt <mirko@openwrt.org>
Sat, 15 Jan 2011 19:08:52 +0000 (19:08 +0000)
committerMirko Vogt <mirko@openwrt.org>
Sat, 15 Jan 2011 19:08:52 +0000 (19:08 +0000)
SVN-Revision: 25010

net/rtorrent/Makefile

index 6fb10db6fca9f2c1f4afa8e0ea148e2199caffb6..cd2a0f5b17f6dcc46f11e301e8e2575825c68262 100644 (file)
@@ -30,7 +30,7 @@ define Package/rtorrent
   CATEGORY:=Network
   TITLE:=BitTorrent client for ncurses
   URL:=http://libtorrent.rakshasa.no/
-  DEPENDS:=+libcurl +libtorrent +libncurses +libsigcxx +xmlrpc-c +libpthread
+  DEPENDS:=+libcurl +libtorrent +libncurses +libsigcxx +xmlrpc-c_server +libpthread
 endef
 
 define Package/rtorrent/description
@@ -44,13 +44,13 @@ ifneq ($(CONFIG_GCC_VERSION_3_4)$(CONFIG_GCC_VERSION_4_1),)
 TARGET_CPPFLAGS += -fno-strict-aliasing
 endif
 
-TARGET_LDFLAGS += -lpthread
+TARGET_LDFLAGS += -lpthread -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
 
 CONFIGURE_ARGS+= \
        --enable-shared \
        --disable-static \
        --disable-debug \
-       --with-xmlrpc-c \
+       --with-xmlrpc-c
 
 define Build/Configure
        (cd $(PKG_BUILD_DIR); ./autogen.sh );