Updated for better use with ppp and dns requests
authorCraig M. Coffee <cmcoffee@gmail.com>
Sat, 24 Apr 2010 00:29:57 +0000 (00:29 +0000)
committerCraig M. Coffee <cmcoffee@gmail.com>
Sat, 24 Apr 2010 00:29:57 +0000 (00:29 +0000)
SVN-Revision: 21116

net/multiwan/Makefile
net/multiwan/files/etc/config/multiwan
net/multiwan/files/usr/bin/multiwan

index 30d6dbb4a655ab71252358ed7802190b4a6d2ba2..628a6f03a75a63edc5d5f702da24c474e11aaa72 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=multiwan
-PKG_VERSION:=1.0k
+PKG_VERSION:=1.0l
 PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -16,9 +16,10 @@ include $(INCLUDE_DIR)/package.mk
 define Package/multiwan
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+ip +iptables +iptables-utils +iptables-mod-conntrack +iptables-mod-conntrack-extra
+  DEPENDS:=+ip +iptables +iptables-utils +iptables-mod-conntrack +iptables-mod-conntrack-extra +iptables-mod-ipopt
   TITLE:=Simple multi WAN configuration
   URL:=ftp://ftp.netlab7.com/
+  MAINTAINER:=Craig M. Coffee <craigc@netlab7.com>
 endef
 
 define Package/multiwan/description
index 9ba84743a9ca85a2988dcdd5b8612079cc95a233..5a28410c84e81230ec06acab271574c235230c5c 100644 (file)
@@ -4,7 +4,7 @@ config 'multiwan' 'config'
        option 'resolv_conf' '/tmp/resolv.conf.auto'
 
 config 'interface' 'wan'
-       option 'weight' '5'
+       option 'weight' '10'
        option 'health_interval' '10'
        option 'icmp_hosts' 'dns'
        option 'timeout' '3'
@@ -13,7 +13,7 @@ config 'interface' 'wan'
        option 'failover_to' 'balancer'
 
 config 'interface' 'wan2'
-       option 'weight' '5'
+       option 'weight' '10'
        option 'health_interval' '10'
        option 'icmp_hosts' 'dns'
        option 'timeout' '3'
index 3160218096722d6b1d1401a75a033cefd9bce710..e0a67a86a41af87c6d982ef01063bf21d3cccf46 100755 (executable)
@@ -601,7 +601,7 @@ ip route flush table 123 > /dev/null 2>&1
 
         for TABLE in 123
         do
-                ip route | grep link | while read ROUTE
+                ip route | grep link | grep -Ev ^default | while read ROUTE
                 do
                 ip route add table $TABLE to $ROUTE
                 done
@@ -657,7 +657,7 @@ ip route flush table $iprule > /dev/null 2>&1
 
         for TABLE in $iprule
         do
-                ip route | grep link | while read ROUTE
+                ip route | grep link | grep -Ev ^default | while read ROUTE
                 do
                 ip route add table $TABLE to $ROUTE
                 done